Z レポートのデータ調整に関する問題
エラー コード: SYS103633
この記事では、本社での Z レポートのデータ調整に関する問題Microsoft Dynamics 365 Commerce解決します。
現象
- Z レポートに表示される金額と、計算されたステートメントに表示される合計の間に不一致があります。
- 本社のトランザクションの行項目数が正しくないか、明細行の合計とトランザクションの合計が一致しません。
- 本社のシフトに表示されるトランザクションの数が、Z レポートのトランザクション数よりも少なくなります。
- 上記のいずれかの理由により、明細書の転記が失敗します。
原因
前に説明した現象の最も一般的な根本原因は、チャネル データベースでの重複トランザクション ID の生成です。 重複するトランザクション ID は、次の理由で生成できます。
- モダン 販売時点管理 (MPOS) のローカル データベース ストレージが破損しています。
- MPOS にはオフライン モードのトランザクションがいくつかあり、オフライン データベースにアクセスできないアカウントを使用して再アクティブ化されます。
- トランザクション ID の生成に関連するカスタマイズに問題があります。
解決方法
通常、Commerce は数値シーケンスに依存してシーケンシャル トランザクション ID を生成します。 何らかの理由で番号シーケンスが使用されたかどうかをシステムが判断できない場合は、重複するトランザクション ID が生成されます。
重複するトランザクション ID の問題を解決するには、サポート チケットを作成して、トランザクション データを修正できるかどうかをチェックします。 場合によっては、本社でデータ損失がない場合など、データの修正や必要はありません。
今後この問題を回避するには、本社で 重複するトランザクション ID を回避するために、[新しいトランザクション ID を有効にする] 機能を有効にする 必要があります。 この機能は、Microsoft Dynamics 365 Commerce バージョン 10.0.19 で導入されました。 これにより、トランザクションごとに一意のトランザクション ID が作成されるようにすることで、シーケンシャル トランザクション ID の作成を防ぐことができます。 この機能の詳細については、「 重複するトランザクション ID を防止する」を参照してください。