Cloud Migration Setup で "レプリケーションを有効にできませんでした" というエラーが発生する
この記事では、Business Central で Cloud Migration Setup assisted setup ガイドを実行したときに発生するエラー メッセージを解決します。
現象
オンプレミスから Business Central オンラインへのデータ移行プロセス中にCloud 移行セットアップ支援セットアップ ガイドを実行すると、次のエラー メッセージが表示されます。
レプリケーションを有効にできませんでした。 統合ランタイムが正常に接続されていることを確認し、もう一度やり直してください。
原因
エラー メッセージにはいくつかの理由が考えられます。 ただし、最も一般的な理由は、オンプレミスのバージョンとオンラインの Business Central バージョンと、Cloud Migration Setup ガイドで選択Product Type の不一致です。
解決方法
Cloud 移行セットアップを実行し、[製品の選択] ページに移動したら、Product Typeがオンプレミスとオンラインのバージョンと一致していることを確認します。 Business Central のバージョン番号には、 Major.Minor.Revision.Build 形式 (20.1.12345.67890 など) が必要です。
- オンプレミスとオンラインのメジャー バージョンが同じ場合 (オンプレミスの場合は 20.1、オンラインの場合は 20.3 など)、 Dynamics Business Central の現在のバージョンを選択します。
- オンプレミスとオンラインのメジャー バージョンが異なる場合 (オンプレミスの場合は 14.3、オンラインの場合は 20.3 など)、 Dynamics Business Central 以前のバージョンを選択。
次の SQL クエリを実行して、オンプレミス データベースに正しいバージョン番号が含まれていることを確認できます。
SELECT [applicationversion]
FROM [$ndo$tenantdatabaseproperty]