Business Central クラウド移行の "SQL Database に接続できません、ErrorCode=SqlFailedToConnect" エラー
この記事では、"Cannot connect to SQL Database, ErrorCode=SqlFailedToConnect" というエラー メッセージを解決します。これは、 Business Central クラウド移行で SQL データベースに接続しようとしたときに発生します。
現象
Business Central クラウド移行で SQL データベースに接続しようとすると、次のエラー メッセージが表示されます。
SQL Database に接続できません。ErrorCode=SqlFailedToConnect。
このエラー メッセージは、多くの場合、次のエラー メッセージと共に発生します。
リンクされたサービス構成が正しいことを確認し、SQL Database ファイアウォールで統合ランタイムがアクセスできることを確認します。
原因
エラー メッセージにはいくつかの理由が考えられます。 最も一般的な理由は、次のような長いエラー メッセージ内で返されます。
ユーザー アカウントに関する問題:
ユーザーのログインに失敗しました...
このアカウントのパスワードを変更する必要があります。
アカウントが無効になっています。
SQL Server が実行されていないか、SQL Server へのリモート アクセスが無効になっています。
サーバーが見つからない、またはアクセスできませんでした。 インスタンス名が正しいかを確認し、さらに SQL Server が構成されリモート接続が許可されていることを確認します。
解決方法
この問題を解決するには、統合ランタイム ホストで次の Windows PowerShell コマンドを実行します。 統合ランタイム ホストが接続できない場合は、わかりやすいエラーが返されます。
sqlcmd –S "{SQL Server Name}" -d "{Database Name}" -U "{SQL Server Authenticated User Name}" -P "{PlaceholderSQLServerAuthenticatedPassword}" -Q 'select * from [dbo].[Intelligent Cloud]'
Integration Runtime クライアント IP アドレスが SQL Server にアクセスできるようにするには、オンプレミスのマスター データベースで次のコマンドを実行します。
sp_set_firewall_rule
SQL Server へのリモート アクセスを許可するには、次のコマンドを実行します。
run sp_configure 'remote access', 1;