Microsoft 365 アクセスが有効になっている場合でも、アクセス許可エラーが発生する
この記事では、Microsoft 365 ライセンスによるアクセスが Business Central 管理センターで適切に有効になっている場合でも、Microsoft Teamsから Business Central レコードにアクセスしようとしたときにユーザーが発生する可能性があるアクセス許可関連の問題を解決する方法について説明します。
現象
ユーザーがMicrosoft Teams会話で Business Central レコードのリンクまたはカードを選択すると、"申し訳ございません。現在のアクセス許可でアクションが妨げられます" のようなエラー メッセージが表示されます。
原因
この動作は仕様です。 管理者はまず、Microsoft Teamsでアクセスできるデータを構成する必要があります。 管理者が Business Central 管理センターでアクセスを有効にしても、 License Configuration ページでアクセス許可を割り当てない場合、Microsoft Teamsの Business Central レコードにアクセスしようとするユーザーには、オブジェクトへのアクセス許可なしでユーザー レコードがプロビジョニングされます。
解決方法
Note
この問題を解決するには、Business Central でテナント管理者のアクセス許可が必要です。
Dynamics 365 Business Central 管理センターで Microsoft 365 アクセスを有効にするだけでなく、 License 構成 ページでアクセス許可を割り当てます。 ただし、 License Configuration ページに割り当てられたアクセス許可は、新しく作成されたユーザーにのみ適用されます。 既に作成されているユーザーの場合は、 Users リスト ページを使用して、不足しているアクセス許可も割り当てる必要があります。