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Windows ライセンス認証 - クライアント マシン ID の重複

適用対象: ✔️ Windows VM

一般に、Azure ハイブリッド特典が有効になっている場合でも、Azure キー管理サービス (KMS) サーバーを使用して Azure Windows 仮想マシン (VM) をアクティブ化することをお勧めします。 ただし、特定のケースでは、ネットワーク制限によって VM が Azure KMS サーバーと通信できなくなる可能性があるため、アクティブ化にはセルフホステッド KMS サーバーを使用できます。 この記事では、Windows ライセンス認証にセルフホステッド KMS サーバーを使用するときに発生するクライアント マシン ID の重複の問題について説明し、解決策を提供します。

Note

この記事は、アクティブ化にセルフホステッド KMS サーバーを使用する場合にのみ適用されます。 アクティブ化に Azure KMS を使用する場合は適用されません。

現象

セルフホステッド KMS サーバーを使用してライセンス認証を行い、複数の Windows Server VM をアクティブ化しようとすると、評価期間後にライセンス認証が失敗し、セルフホステッド KMS サーバーから Duplicate Client Machine ID レポートに次のエラーが報告されます

Duplicate Client Machine ID Report は、デプロイ前に Sysprep ツールを使用して適切に一般化されなかったイメージを実行している環境内のマシンを識別するのに役立ちます。
注意:
- 同じ CMID を持つ複数のボリューム ライセンス認証クライアントは、KMS によって 1 つのクライアントとしてカウントされます。 これにより、KMS クライアント数が最小しきい値を下回った場合、KMS ライセンス認証は環境内で失敗します。

原因

  • クライアント マシン ID (CMID) は、元のソース イメージの Sysprep プロセス中にクリアされます。 ただし、パラメーター SkipRearm 0 の既定値ではなく、1に設定された Sysprep プロセスがトリガーされた場合、CMID はクリアされません。 この場合、このイメージから作成されたすべての VM は同じ CMID を持ちます。

  • Azure Marketplace から VM を作成すると、Windows Server 用の Azure Marketplace イメージは、パラメーター SkipRearm 1に設定されて一般化されています。 そのため、同じ Windows サーバー イメージから作成された VM は同じ CMID を持ちます。

重複する CMID を確認する

VM がソース イメージとバージョンに基づいて同じ CMID を持っているかどうかを確認します。

  1. 問題のある VM で次のコマンドを実行します。

    cscript C:\Windows\System32\slmgr.vbs /dlv
    

    コマンド出力のサンプルを次に示します。

    Most recent activation information:
    Key Management Service client information
        Client Machine ID (CMID): <client-machine-ID>
        Registered KMS machine name: <KMS-machine-name>
    
  2. 問題のある VM のコマンド出力を比較し、VM が同じ CMID を持っているかどうかを確認します。

解決策

  • カスタム イメージから作成された問題のある VM の場合は、パラメーター SkipRearm 0 に設定して元の VM を一般化/sysprep し、CMID がイメージからクリアされるようにします。

  • 既にデプロイされている問題のある VM の場合は、次の手順に従います。

    1. 管理者特権のコマンド プロンプトから slmgr /rearm コマンドを実行します。

    2. VM を再起動します。

    3. 再起動後に VM がオンラインになったら、次のコマンドを実行して CMID が変更されたことを確認します。

      cscript C:\Windows\System32\slmgr.vbs /dlv
      
    4. もう一度アクティブ化をトリガーします。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。