Azure VM の起動時に "ファイル システムをチェックしています" と表示される
適用対象: ✔️ Windows VM
この記事では、Microsoft Azure で Windows 仮想マシン (VM) を起動するときに発生する可能性がある "ファイル システムのチェック" エラーについて説明します。
症状
Windows VM が起動しません。 [ブート診断] で起動のスクリーン ショットを確認すると、次のメッセージの 1 つでチェック ディスク プロセス (chkdsk.exe) が実行されていることがわかります。
- ドライブ (C:) のスキャンと修復
- C: 上のファイル システムのチェック
原因
ファイル システムで NTFS エラーが検出された場合、Windows では次回の再起動時にディスクの整合性がチェックされ、修復されます。 通常、予期しない再起動が VM に発生した場合、または VM シャットダウン プロセスが突然中断された場合にこのようなことが発生します。
ソリューション
ヒント
VM の最新のバックアップがある場合は、そのバックアップから VM の復元を試行して、起動の問題を修正することができます。
チェック ディスク処理が完了すると、Windows は正常に起動します。 VM がチェック ディスク プロセスで停止している場合は、VM 上のチェック ディスクをオフラインで実行してみてください。
バックアップとして、影響を受ける VM の OS ディスクのスナップショットを取得します。 詳細については、ディスクのスナップショットに関する記事を参照してください。
修復 VM で、接続されている OS ディスクで [ディスクの確認] を実行します。 次のサンプルでは、接続された OS ディスクのドライバー文字は E: です
chkdsk E: /f
ディスクの確認が完了したら、修復 VM からディスクを切断し、影響を受ける VM に OS ディスクとしてディスクを再アタッチします。 詳細については、「 Azure portal を使用して OS ディスクを修復 VM に接続して Windows VM をトラブルシューティングするを参照してください。
お問い合わせはこちらから
質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。