HPC レポート データベースのアクセス許可の問題を解決する
この記事では、Microsoft HPC Cluster Manager でハイ パフォーマンス コンピューティング (HPC) レポート データベースのアクセス許可の問題を解決する方法について説明します。
現象
HPC クラスター マネージャーで、HPC 管理コンソールの Charts and Reports ペインで項目を選択すると、クラスター マネージャーはレポート データベースに接続できなくなり、次のテキストのようなエラー メッセージが表示されます。
HPC クラスター マネージャーはレポート データベースに接続できません。 'Data Source=<data-source-name接続文字列確認してください>;Initial Catalog=CHHPCReporting;Integrated Security=True;' でアクセスできることを確認します。
オブジェクト 'GetHelperInfo'、データベース 'CHHPCReporting'、スキーマ 'HpcReportingSp' に対する EXECUTE アクセス許可が拒否されました。
原因
ユーザー アカウントが db_datareader
データベースに追加されていないか、 dbo
スキーマに対する EXECUTE アクセス許可がアカウントに付与されていません。
ソリューション
ユーザー アカウントを追加し、必要なアクセス許可を適用するには、次の手順に従います。
パート 1: HPC データベースを設定し、HPC レポートの管理グループを追加する
Run SetupHpcDatabase スクリプトの手順に従って、HPC データベースと SQL Server サインインの構成を完了します。
[ Start メニューで、 SQL Server Management Studio を検索して選択します。
Microsoft SQL Server Management Studio ウィンドウで、開くファイル アイコンを選択します。
AddHpcReportsAdminGroup.sqlを参照して開きます。
SQL ファイルで、
$(TargetAccount)
のすべてのインスタンスを使用しているアカウント (たとえば、hpc1\guest1
) に置き換えます。Execute アイコンを選択します。 Messages ペインが表示され、"コマンドが正常に完了しました" というメッセージが表示されます。
オブジェクト エクスプローラー ペインで、HPCReporting>Security>Schemas を展開します。
パート 2: HpcReportingSp スキーマに必要なアクセス許可があることを確認する
オブジェクト エクスプローラー ペインで、HpcReportingSp スキーマを選択します。
Properties アイコン (レンチ) を選択します。 Schema プロパティ - HpcReportingSp ダイアログ ボックスが表示されます。
ページの選択 ウィンドウで、Permissions を選択します。
ユーザーまたはロール一覧で、ユーザー アカウントの名前を選択します。 <account-name> セクションの Explicit タブの Permissions には、次のデータ行が含まれます。
権限 Grantor Grant [許可の有無] 拒否 実行 dbo x O O Cancel ボタンを選択します。
パート 3: HpcReportingView スキーマに必要なアクセス許可があることを確認する
オブジェクト エクスプローラー ペインで、HpcReportingView スキーマを選択します。
Properties アイコン (レンチ) を選択します。 Schema プロパティ - HpcReportingView ダイアログ ボックスが表示されます。
ページの選択 ウィンドウで、Permissions を選択します。
ユーザーまたはロール一覧で、ユーザー アカウントの名前を選択します。 <account-name> セクションの Explicit タブの Permissions には、次のデータ行が含まれます。
権限 Grantor Grant [許可の有無] 拒否 Select dbo x O O 定義の表示 dbo x O O Cancel ボタンを選択します。
パート 4: エラーが発生しなくなったことを確認する
HPC クラスター マネージャーで HPC 管理コンソールに移動し、グラフとレポート ペインで項目を選択します。 拒否された EXECUTE アクセス許可に関するダイアログ ボックスのエラー メッセージが表示されなくなりました。
お問い合わせはこちらから
質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。