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回復が続くノード準備ができていないエラーのトラブルシューティング

この記事は、Microsoft Azure Kubernetes Service (AKS) クラスター内のノードにノードの準備ができていない状態が表示され、正常な状態に自動的に回復するシナリオのトラブルシューティングに役立ちます。

現象

ノードが準備ができていないことを報告している間、アプリケーションが応答を停止していることがわかります。 ただし、ノードは自動的に回復し、現在は根本原因分析 (RCA) を探しています。

原因

この問題の原因として考えられるのは、次のシナリオです。

  • API サーバーは使用できません。また、デプロイに準備プローブを使用しています。

    ポッドが実行されていても準備ができていない場合、その状況は、準備プローブが失敗していることを意味します。 準備プローブが失敗した場合、ポッドはサービスにアタッチされず、トラフィックはポッド インスタンスに転送されません。

  • 仮想マシン (VM) ホストエラーが発生します。 VM ホストの障害が発生したかどうかを確認するには、次の情報ソースを確認します。

防止

この問題が今後発生しないようにするには、次の 1 つ以上のアクションを実行します。

  • サービス レベルが完全に支払われるかどうかを確認します。
  • API サーバーへの watch 要求と get 要求の数を減らします。
  • ノード プールを正常なノード プールに置き換えます。

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