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SubscriptionRequestsThrottled エラー コード (429) のトラブルシューティング

この記事では、Microsoft Azure Kubernetes Service (AKS) クラスターを作成してデプロイしようとしたときに発生する SubscriptionRequestsThrottled エラー (状態 429) を特定して解決する方法について説明します。

現象

AKS クラスターを作成しようとすると、次の "標準ロード バランサーの調整に失敗しました" というエラー メッセージが表示されます。このエラー メッセージには、 SubscriptionRequestsThrottled の "SubCode" 値と 429 の "Status" 値が表示されます。

標準ロード バランサーの調整に失敗しました。

詳細: outboundReconciler の再試行に失敗しました:

カテゴリ: ClientError;

SubCode: SubscriptionRequestsThrottled;

依存関係: Microsoft.Network/PublicIPAddresses;

OrginalError: autorest/azure: サービスからエラーが返されました。 Status=429

Code="SubscriptionRequestsThrottled"

Message="サブスクリプション '<subscription-id-guid>' および操作 'GET/SUBSCRIPTIONS/RESOURCEGROUPS/PROVIDERS/MICROSOFT に対する要求の数。NETWORK/PUBLICIPADDRESSES' がバックエンド ストレージの制限を超えました。 '6' 秒後にもう一度お試しください。"。

AKSTeam: ネットワーク、Retriable: false。

要求の調整は異なる Azure コンポーネントで発生する可能性があるため、この問題が発生しているリソースの種類に基づいてエラー メッセージが異なる場合があります。

原因

Azure Resource Manager 要求が調整されています。 Azure Resource Manager での作業の制限方法と 1 時間あたりの具体的な制限については、「 Resource Manager 要求の実行」を参照してください。

解決策 1: 別のサブスクリプションを使用する

別のサブスクリプションにアクセスできる場合は、そのサブスクリプションにクラスターをデプロイするだけです。

解決策 2: アクセス パターンを変更する

この問題を解決するには、調整されたサブスクリプションのアクセス パターンを調べます。 次の表に、使用可能なアクセス パターンと対応するソリューションを示します。

アクセス パターン ソリューション
自動スクリプトによってサブスクリプションが常にスキャンされる スクリプトの実行頻度が低い
多くのユーザーがサブスクリプションにアクセスする 各ユーザーに独自のサブスクリプションを使用させる
スクリプトは、サブスクリプション内のすべてのストレージ アカウントをスキャンします スクリプトのスコープを設定して、必要なリソースのみを照会する

詳細

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質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。