InvalidResourceReference エラー コードのトラブルシューティング
この記事では、Microsoft Azure Kubernetes Service (AKS) クラスターを作成してデプロイしたり、AKS クラスターを更新したりするときに発生する可能性がある InvalidResourceReference
エラーを特定して解決する方法について説明します。
症状 1
AKS クラスターを作成しようとすると、次のエラー メッセージが表示されます。
Code="InvalidResourceReference"
Message="Resource
/subscriptions/<subscription-id-guid>/resourceGroups/MyResourceGroup/providers/Microsoft.Network/virtualNetworks/vnet-otcom/subnets/Subnet-AKS
リソースによって参照される
/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyResourceGroup_MyCluster-AKS_JAPANEAST/providers/Microsoft.Compute/virtualMachineScaleSets/aks-nodepool-vmss
が見つかりませんでした。 参照先のリソースが存在し、両方のリソースが同じリージョンにあることを確認してください。Details=[]
原因 1
この問題の考えられる原因を次に示します。
異なるリージョン内のリソース間に不一致が存在します。
Symptom 1 の例は、仮想ネットワークと仮想マシン スケール セットが同じリージョンにないことを示しています。 リソースは異なるリージョンにあるため、スケール セット インスタンスを作成することはできません。
参照先のリソースが手動で変更または削除されました。
解決策 1
異なるリージョン内のリソース間に不一致が存在する場合は、リソースを確認して、それらが同じリージョンにあることを確認します。 この例では、AKS クラスターが構築されているリージョンを変更するか、同じリージョンに新しい仮想ネットワークを作成します。
参照先のリソースが手動で変更または削除された場合、 MC_ リソース グループ内の基になる IaaS リソースを手動で変更することはサポートされていないため、この問題を解決することが困難な場合があります。 考えられる解決策は、削除されたリソースを再作成し、VMSS と再関連付けしてから、AKS クラスターで更新をトリガーすることです。 ただし、これはサポートされていないシナリオであるため、このソリューションの成功を保証することはできません。
現象 2
AKS クラスターを更新しようとすると、次のエラー メッセージが表示されます。
Code="InvalidResourceReference"
Message="Resource
/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyResourceGroup/providers/Microsoft.Network/loadBalancers/kubernetes/frontendIPConfigurations/<frontendIP_ID> resource /subscriptions/< frontendIP_ID によって参照されるsubscription-id-guid>/resourceGroups/MC_MyResourceGroup/providers/Microsoft.Network/loadBalancers/kubernetes/loadBalancingRules/<frontend_IP_rule> が見つかりませんでした。 参照先のリソースが存在し、両方のリソースが同じリージョンにあることを確認してください。
Message="ResourceDetails=[]
原因 2
この問題は、ロード バランサーの既定の送信規則 "aksOutboundRule" が手動で変更された場合に発生する可能性があります。 この予期しない変更は、通常、 load-balancer-outbound-ips
パラメーターを指定せずにクラスターを更新した場合に、送信 IP が更新されるときに発生します。
解決策 2
クラスターを更新するには、load-balancer-outbound-ips
パラメーターを指定して az aks update
コマンドを再実行します。 パラメーター値としてパブリック IP のリソース ID を使用します。 詳細については、「 独自の送信パブリック IP を使用してクラスターを更新するを参照してください。
詳細
AKS クラスターの作成に関する問題の一般的なトラブルシューティング
お問い合わせはこちらから
質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。