PublicIPAddressCannotBeDeleted、InUseSubnetCannotBeDeleted、または InUseNetworkSecurityGroupCannotBeDeleted エラー コードのトラブルシューティング
この記事では、Microsoft Azure Kubernetes Service (AKS) クラスターを削除しようとしたときに発生する、、InUseSubnetCannotBeDeleted
またはInUseNetworkSecurityGroupCannotBeDeleted
エラーを特定して解決PublicIPAddressCannotBeDeleted
する方法について説明します。
現象
AKS クラスターを削除しようとすると、次のいずれかのエラー メッセージが表示されます。
エラー コードの
PublicIPAddressCannotBeDeleted
場合:{
message: "パブリック IP アドレス ...../providers/Microsoft.Network/publicIPAddresses/ は、リソース ...../providers/Microsoft.Network/loadBalancers/kubernetes/frontendIPConfigurations/..... に割り当てられているため、削除できません . パブリック IP を削除するには、リソースからパブリック IP アドレスの関連付けを解除またはデタッチします。
}
エラー コードの
InUseSubnetCannotBeDeleted
場合:{
message: "Subnet aks-subnet is use by ...../Microsoft.Network/networkInterfaces/|providers|Microsoft.Compute|virtualMachineScaleSets|vmss|virtualMachines|1|networkInterfaces|aks-worker-vmss/ipConfigurations/ipconfig1 とは削除できません。 サブネットを削除するには、サブネット内のすべてのリソースを削除します。
}
または
{
message: "Subnet aks-subnet is use by ..../resourceGroups/.../providers/Microsoft.Network/virtualNetworks/.../subnets/.../serviceAssociationLinks/AppServiceLink は削除できません。 サブネットを削除するには、サブネット内のすべてのリソースを削除します。 「aka.ms/deletesubnet」を参照してください。
}
エラー コードの
InUseNetworkSecurityGroupCannotBeDeleted
場合:{
message: "ネットワーク セキュリティ グループ ...../Microsoft.Network/networkSecurityGroups/test は、...../Microsoft.Network/virtualNetworks/test/subnets/test というリソースによって使用されているため、削除できません。 ネットワーク セキュリティ グループを削除するには、リソースとの関連付けを削除します。
}
原因
AKS クラスターは、サブネット、ネットワーク セキュリティ グループ (NSG)、または現在使用されている特定のパブリック IP アドレスに関連付けられています。 この関連付けにより、クラスターを削除できなくなります。
ソリューション
Azure Load Balancerに関連付けられているすべてのパブリック IP アドレスと、サブネットによって使用されるリソースを削除します。 詳細については、「 パブリック IP アドレスの表示、設定の変更、または削除」を参照してください。
ロード バランサーで、負荷分散規則、正常性プローブ、バックエンド プールの規則を削除します。
NSG とサブネットの場合は、関連付けられているすべてのルールを削除します。 詳細については、「 サブネットまたはネットワーク インターフェイスとネットワーク セキュリティ グループの関連付けまたは関連付けの解除」を参照してください。
サブネットが AKS クラスターの VNET に接続されているApp Service プランを使用している場合は、関連付けられているApp Service プランとその内部リソース (Function App や SQL Azure データベースなど) を削除してから、AKS クラスターの削除を再試行する必要があります。
お問い合わせはこちらから
質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。