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操作を実行できないか、コンテナー グループの状態が正しくない

この記事では、コンテナー グループ操作を実行できない、またはコンテナー グループが正しくない状態にある Microsoft Azure Container Instances のシナリオを解決する方法について説明します。

現象

次の 1 つ以上の問題が発生します。

  • コンテナー グループを削除しようとすると、内部サーバー エラーが発生します。

  • Azure CLI で az container show コマンドを実行しようとすると内部サーバー エラーが原因でコマンドが失敗します。

  • Azure ポータルではコンテナー グループ リソースを表示できますが、それに対する操作は実行できません。

  • コンテナー グループは無効な状態 ( Stopped Failed など) のままです。

原因

関連付けられたコンテナー グループの削除が試行される前に、コンテナー グループのマネージド ID が削除されました。 このシナリオは、この削除順序を手動で実行しようとした場合に発生する可能性があります。 また、開発リソース グループ内のすべてのリソース (すべてのマネージド ID やコンテナー グループを含む) を削除する定期的にスケジュールされたスクリプト (夜間のスクリプト実行など) がある場合にも発生する可能性があります。 スクリプトは、リソースを正しい順序で削除しません。最初に、コンテナー グループの認証に必要なマネージド ID を削除してから、コンテナー グループ自体の削除を試みます。

解決策 1: マネージド ID を削除する前にコンテナー グループを削除する

最初にコンテナー グループを削除し、削除操作が完了するまで待ってから、マネージド ID を削除します。

解決策 2: サポート チケットを開いて、コンテナー グループを不適切な状態から除外する

コンテナー グループ認証に必要なマネージド ID を最初に削除したために、コンテナー グループが正しくない状態のままになっている場合は、サポート チケットを開きます。 Microsoft サポートは、影響を受けるコンテナー グループを停止し、コンテナー グループのセットアップを修正するために必要なその他の手順を実行するのに役立ちます。

詳細

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。