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エラー: "Web ソケットが閉じているか、開けませんでした"

この記事では、Microsoft Azure Container Instances が仮想ネットワークに接続できないようにする "Web ソケットが閉じているか、開けませんでした" というエラー メッセージを解決する方法について説明します。

現象

Azure portal からコンテナーに接続しようとすると、次のエラー メッセージが表示されます。

次の Web ソケット エラーが発生しました: エラー: Web ソケットが閉じているか、開けませんでした。 ネットワーク接続を検証し、再試行してください。

原因

ファイアウォールによってポート 19390 へのアクセスがブロックされます。 コンテナー グループが仮想ネットワークにデプロイされている場合、このポートは Azure portal から Container Instances に接続するために必要です。

ソリューション

ファイアウォールで TCP ポート 19390 へのイングレスを許可します。 少なくとも、Azure portal が接続する必要があるすべてのパブリック クライアント IP アドレスに対して、ファイアウォールがそのポートへのアクセスを許可していることを確認します。

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質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。