コンテナー グループが移行中の状態のままである
この記事では、Microsoft Azure Container Instances でコンテナー グループが無期限に遷移状態のままのときに発生する操作エラーを解決する方法について説明します。 また、コンテナー グループの作成、開始、再起動、、停止、または削除コンテナー グループをするコンテナー グループ操作中に発生するエラーについても説明します。
現象
Azure Kubernetes Service (AKS) クラスターの削除など、コンテナー グループ操作を直接または間接的にトリガーする操作を行うと、次のエラー メッセージが表示されます。
InternalErrorCode: "ContainerGroupTransitioning"
StatusCode: "409"
メッセージ: "コンテナー グループ '<container-group-name>' はまだ移行中です。後で再試行してください。"
原因
コンテナー グループの継続的な開始操作中、コンテナー インスタンス内のサイドカー コンテナーは想定どおりに終了されません。 この状況では、コンテナー グループは Succeeded 状態でスタックします。
解決策 1: コンテナー グループを停止して再起動する
Azure ポータルでContainer インスタンス検索して選択。
コンテナー インスタンスの一覧で、コンテナー グループ (コンテナー インスタンス) の名前を選択します。
コンテナー グループの Overview ページで Stop を選択してコンテナー グループを停止します。 [コンテナー インスタンスの停止] ダイアログ ボックスで、[Yes を選択して、このアクションを確認します。
コンテナー グループが完全に停止するまで待ちます。 (これには最大 3 分かかる場合があります)。
Start を選択して、コンテナー グループをもう一度開始します。
解決策 2: 実行中でないコンテナーのコンテナー グループを停止する (Logic Apps によってデプロイされる)
コンテナーが Azure Logic App を使用してデプロイされている場合コンテナーの状態を確認します。 コンテナーが Running 状態でない場合は、コンテナー グループを停止します。 詳細については、「 Azure Container Instances (ACI) と ACI Logic Apps コネクタを使用したトリガーに基づく感情分析の実行を参照してください。
Note
ベスト プラクティスとして、コンテナー グループを停止または開始する前に、コンテナーの状態を確認することをお勧めします。 実行中のコンテナーが既に存在するコンテナー グループを起動すると、遷移状態の問題が発生する可能性があります。
解決策 3: サポート チケットを開く
上記の解決策で問題が解決せず、それでもエラー メッセージが表示される場合は、サポート チケットを開きます。
詳細
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