Microsoft Entra ID へのディレクトリ同期が停止するか、同期が 1 日を超えて登録されていないことが警告されます
この記事では、Azure Active Directory 同期ツールのパフォーマンスの問題について説明します。 このツールは同期を停止するか、同期が 24 時間以上実行されていないレポートを表示します。
元の製品バージョン: Microsoft Entra ID、Microsoft Intune、Azure Backup、Office 365 Identity Management
元の KB 番号: 2882421
Note
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現象
次のいずれかの現象が発生します。
- Microsoft Azure Active Directory 同期ツールは同期を停止します。
- 過去 24 時間以内に Microsoft Entra ID が同期試行を登録しなかったことを示す電子メール メッセージを受信します。
MIISClient.exe
ツールでは、"Stopped-Server-Down" メッセージまたは "Stopped-Extension-DLL-Exception" メッセージが表示されます。- 1 つ以上のディレクトリ同期サービスを開始できません。
Note
既定では、ディレクトリ同期は 3 時間ごとに実行されます。
原因
この問題は、以下の状況が少なくとも 1 つ該当する場合に発生する可能性があります。
ディレクトリ同期を設定するための構成ウィザードで使用された職場または学校アカウントに、次のいずれかの問題があります。
- アカウントが削除された。
- アカウントが無効になった。
- アカウント パスワードの有効期限が切れた。
1 つ以上のディレクトリ同期サービスのログオン アカウントに、次のいずれかの問題があります。
- アカウントが削除された。
- アカウントが無効になった。
- アカウント パスワードの有効期限が切れた。
Note
ディレクトリ同期サービスのログオン アカウントは自動的に構成されるため、変更しないでください。
ディレクトリ同期に使用されている管理者アカウントが変更された。
ネットワーク接続に問題がある。
ディレクトリ同期サービスが停止しています。
解決方法
方法 1: サービスが開始され、管理者アカウントがサインインできることを手動で確認する
Start を選択し、Run を選択し、「Services.msc」と入力して、OK を選択します。
Microsoft Entra Synchronization アプライアンス サービスを見つけて、サービスが開始されているかどうかを確認します。 サービスが開始されていない場合は、サービスを右クリックし、 Start を選択します。
- Azure Active Directory 同期ツールを使用している場合は、 Azure Active Directory 同期サービスを探します。
- Microsoft Entra Connect を使用している場合は、 Microsoft Azure AD Sync を探します。
ディレクトリ同期に使用されている管理者アカウントがまだ存在することを確認します。 アカウントにサインインが許可されていることを確認します。 アカウントがまだ存在する場合は、パスワードをリセットし、サインインできることを確認します。 メッセージが表示されたら、パスワードを変更します。
ディレクトリ同期の構成に使用されるグローバル管理者アカウントがわからない場合は、ディレクトリ同期アプライアンスをインストールしたサーバーで次の手順に従います。
%ProgramFiles%\Microsoft Azure AD Sync\UIShell\
に移動して、Miisclient.exe を実行します。Note
Microsoft Entra Connect または Azure Active Directory 同期サービスを使用している場合は、 Start を選択し、 Synchronization Service を検索して開きます。
[コネクタ] を選び、Microsoft Entra コネクタをダブルクリックします。
[接続] を選択します。
UserName の値を記録しておきます。 これは、ディレクトリ同期の構成に使われるグローバル管理者アカウントです。
ディレクトリ同期サーバーで、Microsoft Entra 同期アプライアンス構成ウィザードを実行します。 ディレクトリ同期に使われる管理者アカウントの新しいパスワードを入力して、ウィザードの残りの手順に従います。
メッセージが表示されたら、 Force ディレクトリ同期 チェック ボックスをオンにします。
方法 2: ディレクトリ同期サービスのログオン アカウントに関する問題を解決する
Start を選択し、Run を選択し、「Services.msc」と入力して、OK を選択します。
Microsoft Entra Synchronization アプライアンス サービスを見つけます。
- Azure Active Directory 同期ツールを使用している場合は、 Azure Active Directory 同期サービスを探します。
- Microsoft Entra Connect を使用している場合は、 Microsoft Azure AD Sync を探します。サービスを右クリックし、 Properties を選択します。 Log On タブで、一覧表示されているアカウント名を書き留めます。
Note
ローカル システム アカウントとしてログオンするようにディレクトリ同期サービスを再構成することはサポートされていないため、問題が発生する可能性があります。
ドメイン コントローラーまたは管理ツールがインストールされているコンピューターで、Active Directory ユーザーとコンピューター (Dsa.msc) を開き、ドメイン名を右クリックして、Find を選択します。 手順 2 で書き込んだアカウントの名前を入力し、 今すぐ検索を選択します。
- アカウントが見つかる場合は、手順 4 に進みます。
- アカウントが見つからない場合は、削除されている可能性があります。 このアカウントを復元する方法の詳細については、「 Active Directory のごみ箱のステップ バイ ステップ ガイドを参照してください。 アカウントを復元できない場合は、ディレクトリ同期クライアントをアンインストールしてから再インストールする必要があります。
アカウントを右クリックし、 Properties を選択します。 [ Account ] タブの [ Account オプション] で、次の手順 実行します。
- Password が期限切れにならないようにチェック ボックスがオンになっていることを確認します。
- Account が無効になっていることを確認チェック ボックスがオフになっていることを確認します。 次に、次のいずれかのアクションを実行します。
- Account が無効になっている場合はチェック ボックスをオフにしてアカウントを有効にします。 次に、Microsoft Entra Synchronization アプライアンス サービスを再起動します。 これを行うには、 Start を選択し、 Run を選択し、「Services.msc」と入力して、 OK を選択します。 サービスを見つけて右クリックし、 Restart を選択します。
- Azure Active Directory 同期ツールを使用している場合は、 Azure Active Directory 同期サービスを探します。
- Microsoft Entra Connect を使用している場合は、 Microsoft Azure AD Sync を探します。
- Account が無効になっている場合チェック ボックスが既にオフになっている場合は、手順 5 に進みます。
Account が無効になっている場合チェック ボックスが既にオフになっている場合は、アカウントのパスワードが手動で変更されている可能性があります。 新しいパスワードを設定するには、Active Directory ユーザーとコンピューターを開き、アカウントを見つけて右クリックし、[ パスワードの設定を選択してパスワードをリセットします。 次の手順でパスワードを使用する必要があるため、設定したパスワードに注意してください。
ディレクトリ同期サービスのログオン アカウントにパスワードを設定します。
Start を選択し、Run を選択し、「Services.msc」と入力して、OK を選択します。
使用しているクライアントに応じて、次のサービスのパスワードを設定します。 これを行うには、適切なサービスを右クリックし、 Propertiesを選択し、 Log On タブを選択し、パスワードを入力します。
Microsoft Entra 同期クライアント Microsoft Entra Connect
Forefront Identity Manager 同期サービス
SQL Server (MOSONLINE) (存在する場合)
Azure Active Directory 同期サービス
Azure AD Sync新しいパスワードを設定したサービスを開始します。
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