新しい Microsoft 365 グループを作成した後、グループ所有者の検索結果が表示されない
現象
Microsoft 365 グループの所有者が、次のいずれかの検索エンジンを使用して SharePoint Online 検索を実行する場合:
- Microsoft 365 検索ボックス
- エンタープライズ検索センター
- カスタマイズ検索 Web パーツを設計する
- CSOM/REST 検索 API を使用したクエリ
所有者が検索結果内のコンテンツを見つけることができません。
原因
この問題は、グループの所有権ではなく、セキュリティ グループ メンバーシップにのみ関連するクエリのセキュリティ トリミング (ユーザーのアクセス権とメンバーシップに基づくフィルター処理) によって発生します。 Microsoft 365 グループには、メンバーではない所有者を持つことができます。
解決方法
この問題を解決するには、所有者もそのグループのメンバーであることを確認します。 その後、すべての検索結果がグループの所有者に表示されます。
管理ポータルからグループを作成すると、次のダイアログが表示されます。
ここでは、グループの所有者を定義できます。 所有者がメンバーとして自動的に追加されることはありません。
所有者がグループのファーストクラスのメンバーであり、すべてのコンテンツを検索できるようにするには、構成ダイアログを使用して、グループのメンバーとして所有者を明示的に追加する必要があります。
詳細
管理者が新しい Microsoft 365 グループを作成する場合、管理者は常にグループのメンバーとして追加されるとは限りません。 メンバーシップ設定は、グループの作成に使用される実際の管理者ダイアログによって異なります。 所有者がメンバーでない場合、所有者は Microsoft 365 検索インターフェイスと API からグループ内のコンテンツを検索できません。 多くの場合、Microsoft 365 で管理ポータルから新しいグループを作成するときに発生します。
場合によっては、予期される動作である可能性があります。 管理者がユーザーの代わりにグループを作成する場合、管理者がグループのメンバーであることが予期されない場合があります。 管理者は、グループのメンバーを追加および削除することで、グループを引き続き管理できます。
他の場合、グループ管理者もグループの参加者ですが、グループ メンバーとして自分自身を追加できなかったため、意図せず、問題が発生する可能性があります。 Outlook または SharePoint のユーザー インターフェイスからグループを作成する場合、問題ではありません。 グループ作成者が自動的にメンバーになります。
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