Outlook で電子メール メッセージにサイズの大きい添付ファイルを追加すると「添付ファイルのサイズが最大値を越えています」エラーが表示される
元の KB 番号: 2813269
現象
Microsoft Office Outlook 2013 以降のバージョンで電子メール メッセージに添付ファイルを追加すると、次のエラー メッセージが表示されます。
接続するファイルは、サーバーで許可されているよりも大きいです。 ファイルを共有の場所に置き、代わりにリンクを送信してみてください。
原因
この問題は、使用している電子メール アカウントの種類に応じて、以下のいずれかの理由により発生します。
インターネット電子メール アカウント (POP3、IMAP、HTTP)
このエラー メッセージは、Outlook 2013 以降のバージョンでのインターネット電子メール アカウントの既定の添付ファイル サイズ制限 20 MB (20480 KB) が原因で表示されます。 この制限は、ほとんどのインターネット サービス プロバイダーの制限を超える非常に大きい添付ファイルをコンピューターがアップロードしないようにします。 この制限は、20 MB を超える 1 つの大きな添付ファイルを追加しているか、合計サイズが 20 MB を超える複数の添付ファイルを追加しているかに関係なく適用されます。
Microsoft Exchange Server (電子メール アカウント)
Exchange Server メールボックスを使用している場合、1 つ以上のアイテムをメッセージに追加し、添付ファイルの合計サイズが 10 MB (10240 KB) を超えている場合、既定でこのエラー メッセージが表示されます。 この添付ファイルの制限は、Outlook のインターネット電子メール アカウントの制限とは関係ありません。 Exchange メールボックスのこの制限は、Exchange 管理者が [トランスポート設定のプロパティ] ダイアログ ボックスで構成した [最大送信サイズ] 設定によるものです (次のスクリーンショットを参照)。
解決方法
既定の添付ファイルの制限を変更する手順は、Outlook で使用している電子メール アカウントの種類によって決まります。
重要
この記事には、レジストリを変更する方法に関する情報が含まれています。 レジストリを変更する前に必ずレジストリのバックアップを作成してください。 また、問題が発生した場合に備えて、レジストリの復元方法を理解しておいてください。 レジストリをバックアップ、復元、および変更する方法の詳細については、「Windows でレジストリをバックアップおよび復元する方法」を参照してください。
インターネット電子メール アカウント (POP3、IMAP、HTTP)
Outlook でインターネット電子メール アカウントの既定の添付ファイルの制限を変更するには、以下の手順に従います。
Outlook を終了します。
レジストリ エディターを起動します。
次のいずれかのレジストリ サブキーを見つけて、クリックします。
<HKEY_CURRENT_USER\Software\Microsoft\Office\x.0>\Outlook\Preferences
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\ x.0 \Outlook\Preferences注:
- x.0> プレースホルダーは<、Office のバージョン (16.0 = Office 2016、Office 2019、Office LTSC 2021、または Microsoft 365、15.0 = Office 2013) を表します。
- パスが現在存在しない場合は、レジストリに手動でパスを作成します。
このサブキーの下に、下記のレジストリ データを追加します。
値の種類: DWORD
値の名前: MaximumAttachmentSize
値のデータ: 添付ファイルの合計最大許容サイズを指定する整数。 たとえば、30 MB の制限を構成するには、30720 (10 進数) を指定します。注:
- 添付ファイルの制限なしを構成する場合は、値ゼロ (0) を指定します。
- 既定の 20 MB 未満の制限を構成する場合は、20 MB 未満の値を指定します。
レジストリ エディターを終了します。
Outlook を起動します。
Microsoft Exchange Server (電子メール アカウント)
Exchange Server アカウントを使用している場合、インターネット電子メールアカウントの 20 MB の添付ファイル制限は Outlook では使用されません。 代わりに、Outlook では Exchange サーバーで構成されている制限を使用します。 Exchange Server アカウントを使用して送信されるメッセージのサイズの制御に使用される設定を変更するには、以下の手順を実行します。
重要
これらの手順は Exchange Server 2007 に適用されます。 他のバージョンの Exchange の場合、同様の手順に従うことをお勧めします。
この Exchange Server 設定は、Outlook のすべてのバージョンに適用されます。
注: Exchange Server 2007 に接続している場合、Outlook 2016 はサポートされません。 詳細については、「エラー: Outlook 2016 のインストールはお待ちください。現在のメールボックスからメールを受信することはできません」を参照してください。
以下の手順で変更を行うには、Exchange 管理者である必要があります。 通常のユーザーは、Exchange 管理コンソールにアクセスできません。
Exchange 管理コンソールを起動します。
[組織の構成] の下の [ハブ トランスポート] を選択します。 (手順 2 と 3 のスクリーン ショットを以下に示します)
[グローバル設定] タブで、[トランスポート設定] を選択します。
[操作] ウィンドウの [トランスポート設定] セクションで、[プロパティ] を選択します。
[トランスポート設定のプロパティ] ダイアログ ボックスの [全般] タブで [最大送信サイズ (KB)] の値を構成します。
[OK] を選択します。
注:
Exchange サーバーにはさまざまな設定のキャッシュがあるため、この変更は即座に有効にはなりません。 Outlook でこの変更が認識されるまで数時間待機しなければならない場合があります。