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Outlook でパスワードの入力が求められ、Microsoft 365 への接続に先進認証を使用しない

元の KB 番号: 3126599

現象

以下のシナリオについて検討します。

シナリオ 1:

Microsoft Outlook でリモート プロシージャ コール (RPC) を使用し、オンプレミス Exchange Server のプライマリ メールボックスに接続します。さらに、Microsoft 365 の別のメールボックスにも接続します。

シナリオ 2:

Outlook でリモート プロシージャ コール (RPC) を使用して接続しているメールボックスを、Exchange Server から Office 365 に移行します。

これらのシナリオでは、資格情報の入力が求められ、Outlook で Microsoft 365 への接続に先進認証が使用されません。 入力した資格情報は、トークンではなく Microsoft 365 に送信されます。

原因

Outlook で使用可能な認証スキームは、RPC によりサポートされているものに限定されています。 ただし、認証スキームには先進認証は含まれません。

解決方法

重要

このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 変更する前に、問題の発生に備えて復元用にレジストリのバックアップを作成してください。

Exchange Web サービス (EWS) や Autodiscover など、Web サービスの新しい認証方法を Outlook に使用させるため、以下のレジストリ キーを作成します。 ユーザーが強制的に Outlook に先進認証を使用することをお勧めします。

  1. Outlook を終了します。

  2. 使用している Windows のバージョンに応じて、以下のいずれかの手順を使用してレジストリ エディターを起動します。

    • Windows 10、Windows 8.1、または Windows 8: Windows キーを押しながら R キーを押して [ファイル名を指定して実行] ダイアログ ボックスを開きます。 「regedit.exe」 と入力し、Enter キーを押します。
    • Windows 7: [スタート] ボタンをクリックし、[検索] ボックスに「regedit.exe」と入力し、Enter キーを押します。
  3. レジストリ エディターで、次のレジストリ サブキーを見つけて、キーをクリックします。

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。

  5. AlwaysUseMSOAuthForAutoDiscover」 と入力し、Enter キーを押します。

  6. [AlwaysUseMSOAuthForAutoDiscover] を右クリックし、[修正] をクリックします。

  7. [値のデータ] ボックスに「 1」と入力し、[OK] をクリックします。

  8. レジストリ エディターを終了します。

詳細

Office 2013 を実行している場合は、レジストリ キーを使用する前に、Outlook および MSO の双方に 2015 年 12 月 12 日以降の更新プログラムが適用されていることを確認してください。

3114349: 2015 年 12 月 8 日付けの Outlook 2013 更新プログラム (KB3114349)

3114333: 2015 年 12 月 8 日付けの Office 2013 更新プログラム (KB3114333)

注:

Office 2016 を実行している場合は、このレジストリ キーを動作させるための更新プログラムは必要ありません。

リモート プロシージャ コール (RPC) の詳細については、「Microsoft 365 での RPC over HTTP のサポートが 2017 年 10 月 31 日に終了」を参照してください。