"API を使用して Salesforce にアクセスするための CRM 管理者のアクセス許可を要求する" エラー
この記事は、Microsoft Copilot for Sales で Salesforce CRM に接続してサインインした後にエラー メッセージが表示された場合の問題のトラブルシューティングと解決に役立ちます。
注:
Microsoft Sales Copilot は、2024 年 1 月に Microsoft Copilot for Sales としてブランド変更されました。 この記事のスクリーンショットは、近日中に新しい名前で更新されます。
影響を受けるのは誰ですか?
要件の種類 | 説明 |
---|---|
クライアント アプリ | Copilot for Sales Outlook アドイン |
プラットフォーム | Web クライアントとデスクトップ クライアント |
Os | Windows と Mac |
展開 | ユーザーが管理し、管理者が管理する |
CRM | Salesforce |
Users | Salesforce CRM で Copilot for Sales を使用しようとしているユーザー |
現象
Outlook 用 Copilot for Sales アドインを使用して Salesforce CRM にサインインすると、次のエラー メッセージが表示されます。
API を使用して Salesforce にアクセスするための CRM 管理者のアクセス許可を要求する
原因
この問題は、Salesforce に API アクセス許可がない場合に発生します。 ログに次のエラーが表示される場合は、これが問題の根本原因であるかどうかを確認できます。
Exception thrown in VivaSalesContacts/GetContactsByEmailAddress -
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self --->
System.Exception: {
"error": {
"code": 502,
"source": "{APIM SOURCE}",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}",
"error": null,
"source": "Salesforce.Common",
"errors": []
}
}
}
解決方法
管理者は、次の手順に従って、 API Enabled アクセス許可をユーザーまたは影響を受けるユーザーのプロファイルに付与できます。
Salesforce に管理者としてサインインします。
検索ボックスに「User」と入力 します。
左側のナビゲーション ウィンドウで、[ プロファイル] を選択し、影響を受けるユーザーのプロファイルを選択します。
[ 管理アクセス許可] セクションで、[ API Enabled] を選択します。
[保存] を選択します。
詳細
問題がまだ解決しない場合は、 Copilot for Sales - Microsoft Community Hub にアクセスして、エキスパートと関わってください。
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