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"API を使用して Salesforce にアクセスするための CRM 管理者のアクセス許可を要求する" エラー

この記事は、Microsoft Copilot for Sales で Salesforce CRM に接続してサインインした後にエラー メッセージが表示される場合の問題のトラブルシューティングと解決に役立ちます。

Note

Microsoft Sales Copilot は、2024 年 1 月に Microsoft Copilot for Sales としてブランド変更されました。 この記事のスクリーンショットは、近日中に新しい名前で更新されます。

誰が影響を受けますか?

要件タイプ Description
クライアント アプリ Copilot for Sales Outlook アドイン
プラットフォーム Web およびデスクトップ クライアント
OS Windows および Mac
展開 ユーザー管理と管理者管理
CRM セールスフォース
ユーザー Salesforce CRM で Copilot for Sales を使用しようとしているユーザー

現象

Copilot for Sales アドイン for Outlook を使用して Salesforce CRM にサインインすると次のエラー メッセージが表示されます。

API を使用して Salesforce にアクセスするための CRM 管理者のアクセス許可を要求する

API アクセス許可エラーを示すスクリーンショット。

原因

この問題は、Salesforce に API アクセス許可がない場合に発生します。 ログに次のエラーが表示される場合、これが問題の根本原因であるかどうかを確認できます:

Exception thrown in VivaSalesContacts/GetContactsByEmailAddress - 
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId: {CLIENT REQUEST ID HERE}-self ---> 
System.Exception: { 
    "error": { 
        "code": 502, 
        "source": "{APIM SOURCE}", 
        "message": "BadGateway", 
        "innerError": { 
            "status": 502, 
            "message": "Salesforce failed to complete task: Message: **API is disabled for this User**\r\nclientRequestId: {CLIENT REQUEST ID HERE}", 
            "error": null, 
            "source": "Salesforce.Common", 
            "errors": [] 
        } 
    } 
} 

解決方法

管理者は、次の手順に従って、 API Enabled アクセス許可をユーザーまたは影響を受けるユーザーのプロファイルに付与できます。

  1. Salesforce に管理者としてサインインします。

  2. 検索ボックスに ユーザー と入力します。

  3. 左側のナビゲーション ウィンドウで Profiles を選択し、影響を受けるユーザーのプロファイルを選択します。

  4. 管理者権限 セクションで API が有効 を選択します。

  5. [保存] を選択します。

    [プロファイル] ページの [API の有効化] オプションを示すスクリーンショット。

詳細

問題がまだ解決しない場合は、 Copilot for Sales - Microsoft Community Hub にアクセスして、エキスパートと交流してください。

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