Microsoft Cloud サービスにサインインしようとすると"AADSTS65005" エラーが発生する
現象
会社のアプリを使用して、Microsoft 365、Microsoft Intune、Microsoft Dynamics、Microsoft Power BI、Microsoft Azure、Microsoft Entra ID フェデレーション ギャラリー アプリなど、Microsoft Cloud Servicesのいずれかにサインインまたは認証を行うと、次のエラー メッセージが表示されます。
AADSTS65005: クライアント アプリケーションがリソースへのアクセスを要求しました。 クライアントがこのリソースを requiredResourceAccess リストに指定していないため、この要求は失敗しました。
原因
この問題は、会社のアプリがMicrosoft Entra IDに登録されていないか、正しいアクセス許可が適用されていない可能性があるために発生します。
解決方法
この問題を解決するには、アクセスしようとしているサービスに応じて、次のいずれかのリソースを使用します。
- Microsoft 365: Microsoft 365 API にアクセスできるように、アプリをMicrosoft Entra IDに手動で登録する
- Dynamics CRM: Dynamics CRM のアプリケーションを登録する
- フェデレーション シングル サインオン用に構成されたギャラリー アプリケーションへのサインインに関する問題
詳細情報
Microsoft Entra IDにアプリを登録する方法の詳細については、次の Microsoft Web サイトを参照してください。