Windows Defender や Endpoint Protection クライアントのトラブルシューティング
Configuration Manager (現在のブランチ) に適用
Windows Defenderまたは Endpoint Protection で問題が発生した場合は、この記事を使用して次の問題のトラブルシューティングを行います。
- Windows Defenderまたは Endpoint Protection を更新する
- Windows Defenderまたは Endpoint Protection サービスの開始
- インターネット接続の問題
- 検出された脅威を修復できない
Windows Defenderまたは Endpoint Protection を更新する
現象
Windows Defenderまたは Endpoint Protection は、Microsoft Update と自動的に連携して、ウイルスとスパイウェアの定義が最新の状態に保たれるようにします。
このセクションでは、次のような自動更新に関する一般的な問題について説明します。
更新が失敗したことを示すエラー メッセージが表示されます。
更新プログラムをチェックすると、ウイルスとスパイウェアの定義の更新プログラムを確認、ダウンロード、またはインストールできないというエラー メッセージが表示されます。
デバイスがインターネットに接続されていても、更新は失敗します。
更新は、スケジュールどおりに自動的にインストールされません。
原因
更新の問題の最も一般的な原因は、インターネット接続に関する問題です。 他の Web サイトを参照できるため、デバイスがインターネットに接続されていることがわかっている場合は、Windows のインターネット設定との競合が原因で問題が発生する可能性があります。
解決するオプション
手順 1: インターネット設定をリセットする
Web ブラウザーを含め、開いているすべてのプログラムを終了します。
注:
これらのインターネット設定をリセットすると、ブラウザーの一時ファイル、Cookie、閲覧履歴、およびオンライン パスワードが削除されることがあります。 お気に入りは削除されません。
[スタート] メニューに移動し、 を開きます
inetcpl.cpl
。[ 詳細設定 ] タブに切り替えます。
[インターネットのエクスプローラー設定をリセットする] セクションで、[リセット] を選択し、もう一度 [リセット] を選択して確定します。
設定がリセットされたら 、[OK] を選択します 。
Windows Defenderをもう一度更新してみてください。
問題が解決しない場合は、次の手順に進みます。
手順 2: コンピューターで日付と時刻が正しく設定されていることを確認する
エラー メッセージにコード 0x80072f8fが含まれている場合は、コンピューターの日付または時刻の設定が正しくないことが原因で問題が発生している可能性が最も高くなります。 [スタート] メニューに移動し、[設定] を選択し、[時刻 & 言語] を選択し、[日付 & 時刻] を選択します。
手順 3: コンピューターのソフトウェア配布フォルダーの名前を変更する
Windows Update サービスを停止します。
[スタート] に移動し、services.msc を開きます。
Windows Update サービスを選択します。 [アクション] メニューに移動し、[停止] を選択します。
SoftwareDistribution ディレクトリの名前を変更します。
管理者としてコマンド プロンプトを開きます。
次のコマンドを入力します。
cd %windir% ren SoftwareDistribution SDTemp exit
Windows Update サービスを再起動します。
[サービス] ウィンドウに戻ります。
Windows Update サービスを選択します。 [アクション] メニューに移動し、[開始] を選択します。
[サービス] ウィンドウを閉じます。
手順 4: コンピューター上の Microsoft ウイルス対策更新プログラム エンジンをリセットする
管理者としてコマンド プロンプトを開きます。
次のコマンドを入力します。
cd \ cd program files\windows defender MpCmdRun -RemoveDefinitions -all exit
コンピューターを再起動します。
Windows Defenderをもう一度更新してみてください。
問題が解決しない場合は、次の手順に進みます。
手順 5: 定義の更新プログラムを手動でインストールする
手順 6: Microsoft サポートに問い合わせる
これらの手順で問題が解決しない場合は、Microsoft サポートにお問い合わせください。 詳細については、「 サポート オプションとコミュニティ リソース」を参照してください。
Windows Defenderまたは Endpoint Protection サービスの開始
症状
プログラムのサービスが停止したため、Windows Defenderまたは Endpoint Protection がコンピューターを監視していないことを通知するメッセージが表示されます。ここで再起動する必要があります。
ソリューション
手順 1: コンピューターを再起動する
すべてのアプリケーションを閉じて、コンピューターを再起動します。
手順 2: Windows サービスを確認する
[スタート] に移動し、services.msc を開きます。
Windows Defenderウイルス対策サービスを選択します。
[スタートアップの種類] が [自動] に設定されていることを確認します。
[アクション] メニューに移動し、[開始] を選択します。
- このアクションを使用できない場合は、[停止] を選択 します。 サービスが停止するのを待ってから、[ 開始 ] アクションを選択してサービスを再起動します。
このプロセス中に発生する可能性があるエラーに注意してください。 Microsoft サポートに連絡し、エラー情報を入力します。
手順 3: サードパーティのセキュリティ プログラムを削除する
注:
一部のセキュリティ アプリケーションでは完全にアンインストールされません。 以前のセキュリティ アプリケーションを完全に削除するには、クリーンアップ ユーティリティをダウンロードして実行する必要がある場合があります。
[スタート] に移動し、appwiz.cplを開きます。
インストールされているプログラムの一覧で、サードパーティのセキュリティ プログラムをアンインストールします。
コンピューターを再起動します。
注意
セキュリティ プログラムを削除すると、コンピューターが保護されていない可能性があります。 既存のセキュリティ プログラムを削除した後にWindows Defenderのインストールに問題がある場合は、Microsoft サポートにお問い合わせください。 [セキュリティ] 製品ファミリを選択し、次にWindows Defender製品を選択します。
インターネット接続の問題
コンピューターがWindows Updateから最新の更新プログラムを受信するには、インターネットに接続します。
[スタート] に移動し、ncpa.cplを開きます。
接続名を開き、接続 の状態を表示します。
コンピューターが接続されている場合、 IPv4 接続 または IPv6 接続状態 は インターネットです。
コンピューターが接続されていないように見える場合は、接続名を選択し、[ この接続の診断] を選択します。
開いているプログラムを閉じて、コンピューターを再起動します。
検出された脅威を修復できない
Windows Defenderまたは Endpoint Protection が潜在的な脅威を検出すると、脅威を検疫または削除することで脅威を軽減しようとします。 これらの脅威は、圧縮されたアーカイブ (.zip
) 内またはネットワーク共有内に隠れる可能性があります。
ファイルを削除またはスキャンする
検出された脅威が圧縮アーカイブ ファイルにあった場合は、ファイルを参照します。 ファイルを削除するか、手動でスキャンします。 ファイルを右クリックし、[Windows Defenderでスキャン] を選択します。 Windows Defenderがファイル内の追加の脅威を検出すると、通知されます。 その後、適切なアクションを選択できます。
検出された脅威がネットワーク共有に存在する場合は、共有を開き、手動でスキャンします。 ファイルを右クリックし、[Windows Defenderでスキャン] を選択します。 Windows Defenderがネットワーク共有内の追加の脅威を検出すると、通知されます。 その後、適切なアクションを選択できます。
ファイルの配信元がわからない場合は、コンピューターでフル スキャンを実行します。 フル スキャンが完了するまでに時間がかかる場合があります。