REST API は、メールボックスへの要求に対するこのメールボックス エラーに対してまだサポートされていません
元の KB 番号: 4462988
現象
アカウントを使用して Outlook REST API 要求を発行すると、次のエラー メッセージが表示されることがあります。
HTTP エラー: 404
エラー コード: MailboxNotEnabledForRESTAPI または MailboxNotSupportedForRESTAPI
エラー メッセージ: "REST API はまだこのメールボックスでサポートされていません。"
原因
このエラーは、メールボックスが専用の Microsoft Exchange Server 上にあり、有効な Microsoft 365 メールボックスではない場合に発生する可能性があります。
解決方法
有効な Microsoft 365 メールボックスを取得するには、Exchange 管理者にメールボックス アカウントの移行要求を送信します。 管理者アクセス許可を持たないユーザーは、アカウントを移行できません。 メールボックス アカウントを移行する方法については、「 Microsoft 365 の Exchange 管理センターを使用してメールボックス データを移行する方法を参照してください。
詳細
Outlook REST API には、Microsoft 365、Hotmail.com、Live.com、MSN.com、Outlook.com、Passport.com のメールボックス データへのアクセスを有効にする次のサブセットが含まれています。
- 複数の API 呼び出しのバッチ処理
- 予定表 API
- 連絡先 API
- Data Extensions API
- 拡張プロパティ API
- メール API
- プッシュ通知 API
- ストリーミング通知 API (プレビュー)
- People API
- タスク API
- User Photo API
詳細については、「 Outlook REST API (バージョン 2.0)を使用する」を参照してください。