Microsoft 365 の Exchange Online メールボックスに Exchange 自動検出を使用して、Outlook で新規プロファイルをセットアップできない
現象
Microsoft Outlook の [アカウントの追加] ウィザードを使用して Microsoft Office 365 の新規メール アカウントをセットアップしようとしても、Outlook プロファイルが自動的にはセットアップされません。 さらに、Outlook でユーザー プロファイルのサーバー設定をセットアップしようとすると、以下のエラー メッセージが表示されます。
"An encrypted connection to your mail services is not available" (メール サービスに対して、暗号化された接続を使用できません。)
Microsoft Remote Connectivity Analyzer を使用してテストすると、次のエラー メッセージが返されることがあります。
"Autodiscover cannot process the given e-mail address. Only mailboxes and contacts are allowed." (指定されたメール アドレスを自動検出で処理できません。メールボックスおよび連絡先のみ許可されます。)
原因
この問題は、次のいずれかに該当する場合に発生します。
- Outlook の [アカウントの追加] ウィザードの [自動アカウント セットアップ] ページで入力したメール アドレスに誤りがある。
- 使用している Outlook のバージョンに、Exchange Online への自動接続に必要な更新プログラムがインストールされていない。
- ドメインの自動検出 CNAME レコードが存在しない、または誤って設定されている。
- Active Directory 同期を使用する組織では、mail、mailNickname、displayName、および proxyAddresses 属性が、オンプレミスの Active Directoryで同期されたユーザーに対して正しく設定されません。
Note
本記事には、Outlook 2016、Outlook 2013、Exchange Online についての情報が記載されています。 モバイル デバイスから Exchange Online に接続する方法については、「 スマートフォンまたはタブレットで Microsoft 365 をセットアップして使用する」を参照してください。 Outlook をサード パーティのサービスに接続する方法については、サード パーティのメール プロバイダーにお問い合わせください。
解決方法
推奨される方法
方法 1: Microsoft 365 Support and Recovery Assistant を実行する
Note
Microsoft サポートと回復アシスタントのシナリオは、新しい Outlook for Windows では使用できません。
Get Help アプリの Classic Outlook プロファイルセットアップのトラブルシューティング ツール を使用します。
このトラブルシューティング ツールは、自動チェックを実行し、検出された問題を解決するために考えられる解決策を返します。
他のメソッド
カスタム ドメインを使用している場合
方法 1 で問題が解決せず、また Microsoft 365 でカスタム ドメインを使用している場合は、以下の方法を記載順に実行します。 問題が解決しない場合は、次の方法に進みます。
方法 2: Outlook を最新バージョンにアップグレードする
まず、Outlook の [アカウントの追加] ウィザードの [自動アカウント セットアップ] ページに正しいメール アドレスとパスワードが入力されていることを確認します。
Outlook 2010 またはそれ以前のバージョンを使用している場合は、Outlook を最新バージョンにアップグレードします。 詳細については、「Microsoft 365 を PC または Mac にダウンロードしてインストールまたは再インストールする」を参照してください。
Microsoft 365 用に Outlook を設定する方法の詳細については、以下の Microsoft Web サイトを参照してください。
この方法で問題が解決しない場合は、方法 3 に進みます。
方法 3: 自動検出 CNAME レコードが正しく設定されていることを確認する
自動検出 CNAME レコードが存在し、適切に設定されている必要があります。 Outlook を使用して Exchange Online メールボックスに接続する場合は、Exchange 自動検出を設定することを強くお勧めします。 Exchange Online で Outlook に接続するには、自動検出および関連するその他の DNS レコードを適切に設定する必要があります。 管理者は、Microsoft 365 のドメイン トラブルシューティング ウィザードまたは Microsoft リモート接続アナライザーを使用して、レコードが正しく設定されていることを確認できます。
Microsoft 365 のドメイン トラブルシューティング ウィザードを使用する
Microsoft 365 のドメイン トラブルシューティング ウィザードを使用するには、以下の手順に従います。
- 管理者アカウントで Microsoft 365 ポータル (https://portal.office.com) にサインインします。
- Admin を選択してMicrosoft 365 管理センターを開きます。
- 左側のナビゲーション ウィンドウで、 Domainsを選択し、影響を受けるユーザーが使用するドメイン名を選択し、 を選択して ウィザードを開始します。
Microsoft リモート接続アナライザーを使用する
リモート接続アナライザーを使用して、Exchange 自動検出が正常に動作しているかどうかを確認するには、以下の手順に従います。
Web ブラウザーで、以下の Web サイトにある Microsoft リモート接続アナライザー ツールにアクセスします。
フォームのすべての必須フィールドに入力し、 Perform テストを選択します。
テストが完了したら、テストが正常に行われたことを確認します。
テストが正常に実行された場合、自動検出は正常に動作しています。
テストに失敗した場合は、自動検出サービスが正しく設定されているかどうかを確認します。 詳細については、次のリソースを参照してください。
組織のメールボックスがすべて Exchange Online にある場合は、「autodiscover.outlook.com」を指す自動検出 CNAME レコードを追加します。 詳細については、「任意の DNS ホスティング プロバイダーで Microsoft 365 用の DNS レコードを作成する」および「Microsoft 365 の外部ドメイン ネーム システム レコード」を参照してください。
Exchange をハイブリッド展開している場合は、オンプレミスの Exchange サーバーを指すように、既存の SMTP ドメインの自動検出パブリック DNS レコードを設定します。 詳細については、「ハイブリッド展開の前提条件」を参照してください。
方法 4: Active Directory のユーザー属性の値が正しく設定されていることを確認する
Exchange ハイブリッド展開がある場合は、 Get-RemoteMailbox コマンドレットを使用して、影響を受けるユーザーに対して適切な属性が設定されているかどうかを判断できます。 一般的な問題は、これらの属性の 1 つ以上に値が設定されていない場合に発生します。 次の例では、ユーザーに設定する正しい属性を表示します。
Attribute | 例 |
---|---|
primarySMTPAddress | ted@contoso.com |
エイリアス | ted |
displayName | Ted Bremer |
emailAddresses | SMTP: ted@contoso.com X400:c=us;a= ;p=First Organization;o=Exchange;s=Bremer;g=Ted |
remoteRoutingAddress | ted@contoso.mail.onmicrosoft.com |
上記の属性を更新するには、Set-RemoteMailbox コマンドレットを使用できます。
これらの属性に正しい値を設定したら、ディレクトリ同期を強制的に実行した後、Outlook でユーザーのメール アカウントをセットアップします。
カスタム ドメインを使用していない場合
方法 2: Outlook の [アカウントの追加] ウィザードを使用する
方法 1 で問題が解決せず、Microsoft 365 と共にカスタム ドメインを使用していない場合は、Outlook の新しいアカウントの追加ウィザードを使用して、Microsoft 365 にサインアップしたときにユーザーの Exchange Online メールボックスに関連付けられている既定の "onmicrosoft.com" ベースのメール アドレスを使用して Outlook プロファイルを設定できます。 新しいアカウントの追加ウィザードを使用して新しいメール プロファイルを設定する場合は、Microsoft 365 パスワードと既定の Microsoft 365 メール アドレスを <user>@<domain>.onmicrosoft.com ( kim@contoso.onmicrosoft.com など) の形式で指定します。
この方法はサポートされており、独自のバニティまたはカスタム ドメインを持つ予定がないお客様に対して機能します。 また、この方法では自動検出もサポートされています。 メールボックス サーバーの場所を変更した場合は、メールボックス サーバーの新しい場所に従って Outlook プロファイルが更新されます。
詳細
マイクロソフトでは、Microsoft 365 の Exchange Online メールボックスへの接続プロファイルを Outlook に手動でセットアップすることはサポートしていません。 ただし、方法 2 で説明したように、DNS レコードや自動検出レコードの設定など、他のタスクを完了するのに役立ちます。 この方法では、サポートされている方法を使用してアカウントを設定できます。
さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。