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アプリ接続の設定時に認定パスのトラスト アンカーが見つかりません

現象

サプライ チェーン管理に接続しようとすると、Warehouse Management アプリに次のエラー メッセージが表示されることがあります。

java.security.cert.certPathValidatorException: 認定パスのトラスト アンカーが見つかりません。

この問題は、次のプロパティを持つデバイスに影響する可能性があります。

  • OS バージョン: Android 4.4.x (Zebra TC55 など)。 これは、最近の Android バージョンでは問題ではありません。
  • サプライ チェーン管理の場所: クラウド
  • 接続モード: クライアント シークレットまたは証明書

考えられる原因

Microsoft は、サプライ チェーン管理で使用されるサーバー SSL 証明書を更新した可能性があります。 その結果、ルート証明書または中間証明書のいずれかが変更された可能性があるため、新しい証明書はモバイル デバイスの信頼されたシステム証明書の一覧に表示されません。 新しいバージョンの Android では、信頼できる証明書の一覧が自動的に更新されますが、Android 4.4.x では更新されません。

解決方法

この問題を解決するには、次のいずれかを行ってください。

  • 次のセクションで説明する回避策を使用して、関連する各デバイスを更新します。
  • Zebra または Google に連絡して、システムの信頼された証明機関 (CA) 証明書の更新プログラムを取得できます。 ただし、これは確認されていません。
  • 可能であれば、古いデバイスを、より新しいバージョンの Android を実行しているデバイス (信頼された CA 証明書が自動的に更新される) に置き換えることを検討してください。

回避策

手順 1: サプライ チェーン管理から新しいルート証明書をエクスポートする

次の手順を実行して、インターネット ブラウザーを使用して新しいルート証明書を手動でダウンロードします。

  1. Dynamics Supply Chain Management にサインインし、フロント ページを開きます。
  2. ブラウザーのアドレス バーで、ロック アイコンを選択して Location is secure ダイアログ ボックスを開きます。
  3. ダイアログ ボックスで、 Certificate (有効) を選択して、その証明書の Certificate ウィンドウを開きます。
  4. Certificate ウィンドウの Certification パス タブを開きます。
  5. 階層内に表示される一番上の証明書を選択します。 (これはルート証明書です)。
  6. Certificate ウィンドウの Details タブを開きます。
  7. Details タブの下部にある [Copy to file ボタンを選択します。
  8. Certificate エクスポート ウィザードが開きます。 [次へ] を選んで続行します。
  9. Export ファイル形式ページが開きます。 [ DER でエンコードされたバイナリ X.509 (.CER)[Next](次へ) をクリックして続行します。
  10. エクスポートする ファイル ページが開き、ファイル名と場所を指定します。 [Next](次へ) をクリックして続行します。
  11. 証明書のエクスポート ウィザードの完了ページが開き、エクスポートの結果が表示されます。 完了 を選択します。

手順 2: ダウンロードした証明書を影響を受けるデバイスにインストールする

次の手順を実行して、ダウンロードした証明書をインストールします。

  1. 前の手順でダウンロードした証明書を、更新するデバイスに転送します。 たとえば、SD カードまたはネットワーク接続を使用して、デバイスでファイルを使用できるようにします。
  2. デバイスのセキュリティ設定を開き、メニュー オプションを選択してファイルから証明書をインストールします。 (これに対する正確な手順は、デバイスと OS のバージョンによって異なります)。
  3. これで、信頼できる証明書の User タブに新しい証明書が表示されます。
  4. 影響を受けるデバイスごとに、この手順を繰り返します。