次の方法で共有


WCF 以外の基幹業務アダプターのトラブルシューティング

''取得できませんでした" エラー

WCF 以外の基幹業務 (LOB) アダプターを使用する場合、次のエラーが発生することがあります。

  • システムを取得できませんでした

  • 参照エージェント: コンストラクターにトラップされたエラー。 ターゲット マシンは能動的に接続を拒否しました。

  • ランタイム エージェント: コンストラクターにトラップされたエラー。 ターゲット マシンは能動的に接続を拒否しました。

原因

基幹業務 (LOB) アダプターが .Net リモート処理を使用しています。 .Net リモート処理のライセンス認証に予想より時間がかかる場合、アダプターがこれらのエラーを返していることがあります。

解決方法

StartAgentSleep レジストリ キーを作成し、タイムアウト値を増やします。

  1. レジストリを開き、 HKEY_LOCAL_MACHINE\software\Microsoft\BizTalkAdaptersに移動します。

  2. 次のプロパティで新しい DWORD 値を作成します。

    名前: StartAgentSleep

    Base: Decimal

    値データ: 1000

    値のデータはミリ秒 (ms) 単位で指定します。 1000ms が 1 秒です。

    一部のシステムでは 1 秒では足りない可能性があります。 値を大きくし、テストして妥当なタイムアウトかどうか判断します。

重要

StartAgentSleep レジストリ キーを追加すると、WCF 以外のすべての LOB アダプターに影響します。

参照

BizTalk Server アダプターのトラブルシューティング