Azure Digital Twins Explorer のトラブルシューティング: 認証エラー
この記事では、Azure Digital Twins Explorer の実行中に認証エラーを受け取った場合の原因と解決手順について説明します。
現象
Azure Digital Twins Explorer を実行すると、次のようなエラー メッセージが表示されます。
原因
原因 #1
このエラーは、Azure Digital Twins インスタンスで必要な Azure のロールベースのアクセス制御 (Azure RBAC) のアクセス許可が Azure アカウントに設定されていない場合にも発生します。 インスタンス内のデータにアクセスするには、読み取りまたは管理を行おうとしているインスタンスで、それぞれ、Azure Digital Twins データ リーダーまたは Azure Digital Twins データ所有者のロールが必要です。
Azure Digital Twins のセキュリティとロールの詳細については、Azure Digital Twins ソリューションのセキュリティに関する記事を参照してください。
ソリューション
解決策 #1
データを読み取るだけの場合は、Azure Digital Twins インスタンスに対する Azure Digital Twins データ リーダー ロールが、またデータを管理しようとしている場合は、インスタンスに対する Azure Digital Twins データ所有者ロールが、Azure ユーザーにあることを確認します。
このロールは以下とは異なることに注意してください。
- 以前、プレビュー期間中に付けられていたこのロールの名前 "Azure Digital Twins 所有者 (プレビュー) " (ロールは同じですが、名前が変更されています)
- Azure サブスクリプション全体に対する "所有者" ロール。 "Azure Digital Twins データ所有者" は、Azure Digital Twins 内のロールであり、この個別の Azure Digital Twins インスタンスにスコープが設定されています。
- Azure Digital Twins での "所有者" ロール。 これらは 2 つの個別の Azure Digital Twins 管理ロールであり、"Azure Digital Twins データ所有者" は管理に使用する必要があるロールです。
このロールがない場合は、それを設定して問題を解決します。
現在の設定を確認する
ロールの割り当てを正常に設定したことを確認するための 1 つの方法として、Azure portal で Azure Digital Twins インスタンスのロールの割り当てを表示します。 Azure portal で Azure Digital Twins インスタンスに移動します。 そこに移動するには、Azure Digital Twins インスタンスのページで検索するか、ポータルの検索バーでその名前を検索します。
次に、[アクセス制御 (IAM)] [ロールの割り当て] で、それに割り当てられているすべてのロールを表示します。 ロールの割り当てが一覧に表示されます。
問題を修正する
このロールが割り当てられていない場合は、お使いの Azure サブスクリプションでの所有者ロールを持っているユーザーに、次のコマンドを実行して、お使いの Azure ユーザーに Azure Digital Twins インスタンスでの適切なロールを付与してもらう必要があります。
サブスクリプション上でご自身が所有者になっている場合は、このコマンドを自分で実行できます。 そうでない場合は、所有者に連絡して、このコマンドを代わりに実行してもらいます。 ロールの名前は、編集アクセスの場合は Azure Digital Twins データ所有者、読み取りアクセスの場合は Azure Digital Twins データ リーダーです。
az dt role-assignment create --dt-name <your-Azure-Digital-Twins-instance> --assignee "<your-Azure-AD-email>" --role "<role-name>"
このロールの要件と割り当てプロセスについて詳しくは、「ユーザーのアクセス許可を設定する」をご覧ください。
次のステップ
新しい Azure Digital Twins インスタンスを作成して認証するための設定手順を確認してください。
Azure Digital Twins のセキュリティとアクセス許可の詳細を確認します。