次の方法で共有


Partner Connect のトラブルシューティング

このセクションでは、パートナー Connect に関する一般的な問題の解決に役立つ情報を提供します。

一般的なエラーのトラブルシューティング

Partner Connect を使って接続しようとすると、次の一般的なエラーが表示されることがあります。

パートナーに接続しようとすると、エラー メッセージが表示される

問題点: パートナー Connect を使用して Azure Databricks ワークスペースをパートナー ソリューションに接続しようとすると、エラーが表示され、接続を作成することができない。

原因:

この問題が発生する理由は複数あります。

  • 組織内の複数のユーザーがパートナーとのアカウントを作成しようとした場合、最初のユーザーのみが成功します。 これは、パートナーはいくつかのアカウントを組織レベルでのみ提供している可能性があり、そのようなアカウントを作成する最初のユーザーも組織のアカウントを確立するためです。
  • パートナーとのアカウントを既に持っている場合でも、接続が失敗することがあります。 これは、パートナーが誤って重複するアカウントを作成しようとしたためです。

解決策:

次のいずれかの操作を行います。

  • パートナーとの組織アカウントを作成した最初のユーザーに、そのアカウントに自身のメール アドレスを追加するよう依頼します。 次に、パートナー Connect をバイパスし、パートナー アカウントに直接サインインして、パートナーのソリューションの使用を開始します。
  • パートナー Connect を使用して、もう一度接続してみてください。ただし、今回は個人のメール アドレスなど、組織のドメインに関連付けられていないメール アドレスを指定します。 このとき、Azure Databricks ワークスペースにそのメール アドレスをユーザーとして追加することが必要になる場合があります。
  • パートナー Connect をバイパスして、既存のアカウントを使用して直接パートナーにサインインし、パートナー ソリューションの使用を開始します。

パートナーへのサインイン後にワークスペースがまだ接続されていない場合は、該当するパートナー接続ガイドの手順に従って、接続を完了してください。

パートナーのアカウントまたは Web サイトにサインインしようとすると、ポップアップ ブロックが表示される

問題点: パートナー Connect を使用してパートナーのアカウントまたは Web サイトにサインインするパートナー ソリューションの場合、[サインイン] をクリックすると、パートナー Connect によって Web ブラウザーに新しいタブが開き、ポップアップ ブロックが表示される。 このポップアップ ブロックにより、パートナーのアカウントまたは Web サイトへのサインインが阻止される。

原因: Web ブラウザーがポップアップをブロックしています。

解決方法: Web ブラウザーでパートナーの Web サイトのポップアップを許可します。 具体的な手順は、Web ブラウザーによって異なります。 たとえば、Google Chrome の場合は、Google Chrome ヘルプ Web サイトの「Chrome でポップアップをブロックまたは許可する」を参照してください。 その他の Web ブラウザーの場合は、「特定の Web サイトのポップアップを許可するにはどうすればよいですか」などの語句でインターネット検索してください。

パートナー接続を作成するためのアクセス許可が不十分です

問題: パートナー接続を作成しようとすると、アクセス許可エラーが表示され、接続を作成できません。

原因: この問題は、お客様がワークスペース管理者でないために発生している可能性があります。

解決策: アカウント管理者またはワークスペース管理者が、該当するユーザーを管理者グループに追加する必要があります。 「グループの管理」を参照してください。

Unity Catalog によって管理されるデータへのパートナー接続を作成するためのアクセス許可が不十分です

問題: パートナー接続を作成しようとすると、"アクセス許可がありません" というエラーが表示され、接続を作成できません。

You do not have permission to grant <read|write> access to the workspace default catalog. To enable granting <read|write> access to the default catalog or other catalogs, contact an account admin

原因: この問題は、お客様がワークスペースの既定のカタログを所有していないために発生している可能性があります。 パートナー ソリューションが、Partner Connect を使用した Unity Catalog に対して有効になっていない場合、接続できるのは既定のカタログのみとなります。既定のカタログは、hive_metastore、またはお客様が別に明示的に所有しているカタログとする必要があります。

解決策: 次のいずれかの操作を行います。

  • 既定のカタログの所有者に、接続の作成を依頼します。

  • 既定のカタログの所有者に、自分を既定のカタログの所有グループに追加してくれるよう依頼します。 「グループの管理」を参照してください。

  • databricks metastores assign を実行することで、既定のカタログを変更するようにアカウント管理者に依頼します。 次のコマンドの例では、次のプレースホルダーを置き換えます。

    • <workspace-id> をワークスペースの ID に置き換えます。
    • <metastore-id> を メタストアの ID に置き換えます。
    • <catalog-name> を既定のカタログの名前に置き換えます。
    databricks metastores assign <workspace-id> <metastore-id> <catalog-name>
    

    警告

    既定のカタログを変更すると、それに依存する既存のデータ操作が中断される可能性があります。 特に、カタログを指定していないデータ操作では、既定のカタログが想定されます。 既定値を変更すると、それらの操作では、参照するデータ オブジェクトを見つけることができなくなります。

    databricks metastores コマンドの詳細については、「Databricks CLI コマンド」を参照してください。

既存のパートナー接続が Azure Databricks データにアクセスできなりました

問題: お客様が、Partner Connect によってご利用のワークスペースに接続するための既存のパートナー アカウントにサインインし、パートナーが Azure Databricks データへのアクセスを試みた場合、ワークスペースの既定のカタログにアクセスする権限がお客様にないことを示すエラーが表示されます。

原因: ご利用のワークスペースが Unity Catalog 対応である場合、既定のカタログが hive_metastore でないことが原因で、この問題が発生する可能性があります。 Unity Catalog で管理されているデータに Partner Connect を使用して接続することが、パートナー ソリューションでサポートされていない場合は、それが原因で、ご利用の既存の接続が切断されます。

解決策: 次のいずれかの操作を行います。

  • パートナーから切断してから再接続し、既定のカタログを指定します。 「パートナーからの切断」を参照してください。 この解決策では、既定のカタログを所有している必要があります。

  • databricks metastores assign を実行することで、既定のカタログを hive_metastore に変更するようにアカウント管理者に依頼してください。 次のコマンドの例では、次のプレースホルダーを置き換えます。

    • <workspace-id> をワークスペースの ID に置き換えます。
    • <metastore-id> を メタストアの ID に置き換えます。
    databricks metastores assign <workspace-id> <metastore-id> hive_metastore
    

    警告

    既定のカタログを変更すると、それに依存する既存のデータ操作が中断される可能性があります。 特に、カタログを指定していないデータ操作では、既定のカタログが想定されます。 既定値を変更すると、それらの操作では、参照するデータ オブジェクトを見つけることができなくなります。

    databricks metastores コマンドの詳細については、「Databricks CLI コマンド」を参照してください。

セキュリティ エラーのトラブルシューティング

このセクションで説明するセキュリティ構成により、Partner Connect の統合が失敗する可能性があります。

IP アクセス リスト

問題: [Connect to partner] (パートナーに接続) ダイアログ ボックスに次の警告が表示され、パートナーへの接続を作成できません。

Partner Connect might not work because IP access list is enabled.

原因: ワークスペースで IP アクセス リスト機能が有効になっている場合、パートナー統合を許可リストに追加することが必要な場合があります。

解決策: パートナー統合を許可リストに追加する手順については、パートナーのドキュメントを参照するか、パートナーのサポート チームにお問い合わせください。

IP アクセス リストについて詳しくは、「ワークスペース向けの IP アクセス リストを構成する」を参照してください。

次の場合は、このセクションの解決策に従って Azure Private Link 設定を構成し、パートナー統合を有効にします。

  • ワークスペースのフロントエンド Private Link 接続を有効にしている

  • Partner Connect で次のエラーが発生する

    Partner Connect might not work because front-end Private Link is enabled.
    

解決策: パートナー統合を有効にするために Private Link 設定を構成します。 Private Link 設定を構成するステップについては、パートナーのドキュメントを参照するか、パートナーのサポート チームにお問い合わせください。

Azure Private Link, の詳細については、「Azure Private Link のバックエンド接続とフロントエンド接続を有効にする」を参照してください。

個人用アクセス トークン

問題: 接続を作成しようとすると、アクセス許可がないことを示す次のエラーが表示されます。

Partner Connect requires personal access tokens to be enabled.

原因: ワークスペースでトークン ベースの認証が無効になっている場合、Microsoft Entra ID トークンまたは Microsoft Entra ID アカウントの資格情報を使って Power BI または Tableau での認証を行わない限り、Partner Connect を使ってパートナー ソリューションと統合することはできません。

個人用アクセス トークンの詳細については、「 Monitor」を参照し、個人用アクセス トークンを取り消します