次の方法で共有


Azure にクラウド サービス (クラシック) をデプロイするときの OverconstrainedAllocationRequest のトラブルシューティング

重要

Cloud Services (クラシック) は、2024 年 9 月 1 日をもって、すべてのお客様に対して非推奨になりました。 既存の実行中のデプロイはすべて Microsoft によって停止およびシャットダウンされ、2024 年 10 月以降、データは永久に失われます。 新しいデプロイでは、新しい Azure Resource Manager ベースのデプロイ モデル、 Azure Cloud Services (延長サポート) を使用してください。

この記事では、Azure Cloud Services (クラシック) のデプロイを妨げている、制約された割り当てエラーのトラブルシューティングを行います。

インスタンスをクラウド サービスにデプロイした場合や、新しい Web ロール インスタンスまたは worker ロール インスタンスを追加した場合に、Microsoft Azure によってコンピューティング リソースが割り当てられます。

これらの操作を行っているときには、Azure サブスクリプションの制限に達していなくても、エラーが発生する場合があります。

ヒント

この情報は、サービスのデプロイを計画する場合にも役立ちます。

症状

[操作ログ (クラシック)] ブレードを示す画像。

例外の種類 エラー メッセージ
OverconstrainedAllocationRequest デプロイ要求の制約条件のため、このデプロイに必要な仮想マシン (VM) サイズ (または VM サイズの組み合わせ) をプロビジョニングできません。 可能であれば、仮想ネットワークのバインドなどの制約を緩和してみてください。 また、他のデプロイがなくアフィニティ グループが異なるホステッド サービスへのデプロイ、アフィニティ グループのないホステッド サービスへのデプロイを試してください。 まったく別のリージョンへのデプロイを試してみることもできます。

原因

クラウド サービスが固定されているか、固定されていないかで、根本原因は異なります。

注意

最初のインスタンスを (ステージング環境または運用環境の) クラウド サービスにデプロイすると、このクラウド サービスは 1 つのクラスターに固定されます。

時間が経過すると、このクラスター内のリソースが完全に使用されてしまう可能性があります。 固定されたクラスターで利用できるリソースが不足し、クラウド サービス (クラシック) によって追加リソースの割り当てが要求された場合、その要求によって割り当てエラーが発生します。

解決策

以下のシナリオの割り当てエラーに関するガイダンスに従ってください。

クラスターに固定されていない

クラウド サービス (クラシック) を初めてデプロイするときは、クラスターがまだ選択されていないため、クラウド サービスは固定されません。 次の理由により Azure でデプロイ エラーが発生する可能性があります。

  • そのリージョンでは利用できない、特定のサイズを選択しました。
  • さまざまなロール全体で必要なサイズの組み合わせを、リージョンで利用できません。

このシナリオで割り当てエラーが発生する場合は、リージョンで使用可能なサイズを確認し、前に指定したサイズを変更することをお勧めします。

  1. クラウド サービス (クラシック) 製品のページで、リージョンで使用可能なサイズを確認できます。

    注意

    "製品" のページには、使用可能な容量は表示されません。 新しい割り当ての場合、その時点で Azure によりリージョン内の最適なクラスターを選択できるはずです。

  2. クラウド サービス (クラシック) のサービス定義ファイルを更新して、リージョンから異なる製品サイズを指定します。

クラスターに固定されている

既存のクラウド サービスは、クラスターに "固定" されています。 クラウド サービス (クラシック) の今後のデプロイは、すべて同じクラスターで行われます。

このシナリオで割り当てエラーが発生する場合は、新しいクラウド サービス (クラシック) に再デプロイし、CNAME を更新することをお勧めします。

ヒント

このソリューションではそのリージョン内のすべてのクラスターからプラットフォームを選択できるため、成功する可能性が最も高くなります。

注意

この解決方法ではダウンタイムは発生しません。

  1. 新しいクラウド サービス (クラシック) にワークロードをデプロイします。

    警告

    このデプロイ スロットに関連付けられている IP アドレスが失われないようにするには、ソリューション 3 の IP アドレスの保持を使用できます。

  2. 新しいクラウド サービス (クラシック) へのトラフィックを指すように、CNAME または A レコードを更新します。

  3. 以前のサイトに送信されるトラフィックが 0 個になると、以前のクラウド サービス (クラシック) を削除できます。

詳細な修復手順については、クラウド サービス (クラシック) の割り当てエラーのトラブルシューティング | Microsoft Docs に関するページを参照してください。

次のステップ

割り当てエラーの解決策と背景情報の詳細:

この記事で Azure の問題が解決されない場合は、Microsoft Developer Network (MSDN) と Stack Overflow の Azure フォーラムにアクセスしてください。 これらのフォーラムの中に問題を投稿するか、X の @AzureSupport に投稿できます。Azure サポート要求を送信することもできます。 サポート要求を送信するには、[Azure サポート] ページで [サポートを受ける] を選択します。