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AKS Edge Essentials の一般的な問題のトラブルシューティング

この記事では、AKS Edge Essentials を使用するときに発生する問題の解決策を見つける方法について説明します。 既知の問題とエラーは、機能領域別に整理されています。 この記事に記載されているリンクを使用して、それらを解決するための解決策と回避策を見つけることができます。

サポート要求をオープンする

Azure portal を使用してサポートを受けたり、AKS Edge Essentials のサポート 要求を開いたりする方法については、 Get のサポート に関する記事を参照してください。

デプロイの問題

信頼されていない発行元の問題

エラー メッセージ: "この信頼されていない発行元からソフトウェアを実行しますか? ....."

回避策: PowerShell 実行ポリシーを RemoteSigned に更新します:

# Get the execution policy on the system
Get-ExecutionPolicy
# Set the execution policy for this process only
if ((Get-ExecutionPolicy) -ne "RemoteSigned") { Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope Process -Force }

ディスク領域が不足すると、以前にキャッシュされたコンテナー イメージが削除されます

ノードのディスク領域が不足すると、事前に読み込まれたイメージの一部は、 containerd ランタイムによってガベージ コレクションされます。 この場合は、まずディスク領域を解放してから、次のコマンドを実行してキャッシュされたイメージをもう一度プルします。

    Invoke-AksEdgeNodeCommand -NodeType Linux -command "sudo /path/to/script/reimport-ci.sh

このスクリプトは、不足しているイメージをチェックし、必要に応じて再インポートします。

Azure Arc 接続

  1. 問題: Disconnect-AksEdgeArc はクラスターからポッドを削除しません。

    回避策: ポッドがクリーンアップされない場合は、次のコマンドを実行して既存の Azure Arc 関連リソースを手動でクリーンアップしてから、再接続を試みます。

    kubectl delete ns azure-arc
    kubectl delete clusterrolebinding azure-arc-operator
    kubectl delete secret sh.helm.release.v1.azure-arc.v1
    
  2. 問題: Azure Arc 接続がプロキシ環境で機能しない。

    回避策: システム全体のプロキシ設定を有効にするには、接続> LAN 設定>Internet オプションに従います。

    インターネット オプションを示すスクリーンショット。

PodDisruptionBudget (PDB) リソースを使用して AKS Arc クラスターを完全に削除できない

この既知の問題については、AKS Arc ドキュメントの「PDB リソースを使用して AKS Arc クラスターを完全に削除できない」を参照してください。

オフライン展開

nodeagent 証明書の取得に失敗しました: 見つかりません

ネットワーク アダプターの構成を確認します。 デプロイ時に、AKS Edge Essentials には、有効で、正しい IP アドレス、サブネット、および既定のゲートウェイを持つアダプターが必要です。 これらの値は、DHCP 環境で自動的に設定されます。 手動で設定する場合は、3 つすべてが設定されていることを確認します。 多くの場合、既定のゲートウェイが設定されていないため、このエラーが発生します。

Kubernetes

Kube-vip ポッドが継続的に再起動する

一部のシナリオでは、 kube-vip ポッドはループして継続的に再起動します。

検証

発生しているシナリオがこの記事に記載されているのと同じ問題であることを確認するには、次のコマンドを実行して、 kube-system 名前空間の kube-vip ポッドに多数の再起動があることを確認します。

kubectl get pods –n kube-system

原因

kube-vip ポッドが絶えず再起動する理由には、いくつかの異なる理由があります。 これらの原因は次のとおりです。

  • SSD ディスクでバックアップされていない OS ディスク、または Azure VM を使用する場合の Premium SSD ディスクの使用。 ハードウェア要件 確認できます
  • ディスクの待ち時間が長すぎます。 ディスク待機時間が 10 ミリ秒を超えると、要求のタイムアウト、リーダーの損失、クラスターの不安定性が生じる可能性があります。 etcd のハードウェア要件 確認できます

解決方法

この問題を軽減するには、基になるストレージ インフラストラクチャを確認して、etcd と AKS Edge Essentials のパフォーマンス要件を満たしていることを確認します。 また、Premium SSD ベースのストレージを使用するか、パフォーマンスのためにストレージ構成を最適化することを検討してください。

次のステップ

AKS Edge Essentials の概要