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"Sorry, OneDrive can't add your folder right now."

ISSUE:

When trying to sync a OneDrive or SharePoint team site, you receive a message "Sorry, OneDrive can't add your folder right now."

POSSIBLE CAUSES:

1. “Require Check Out” was enabled on the library.
2. There are Required columns
3. The 'Draft Item Security' is set to 'Only users who can edit items'
4. Syncing using an external or guest account for OneDrive

RESOLUTION:

1. - Update the “Require Check Out” setting to No.

Steps to change setting:

-In Classic View of the OneDrive/SharePoint library, click the Settings gear and turn the Ribbon On (if not already on)

gear

-Select the Library tab

library-tab

-Choose Library Settings

library-settings

Select Versioning Settings

versioning-settings

-Change the Require Check Out from Yes to No

required-checkout-setting

-Click OK

2. Remove any required columns

-Go to Library Settings page

library-settings

-Inspect each column and remove required restriction or validation formula if applicable.

required-column

- Select the Required column to edit and changed the 'Require this column to contain information' to No

update-required-column

3. Check the 'Draft Item Security' and make sure it is set to 'Any user who can read items'

-Go to Library Settings page

library-settings

-Click on Versioning Settings

versioning-settings

-In the Versioning Settings, check the 'Draft Item Security' and make sure it is set to 'Any user who can read

draft-item-security

4. Synchronizing content using an external or guest user is currently not supported by OneDrive -

Comments

  • Anonymous
    March 15, 2017
    This solution does not resolve my problem. I have used previous versions of the sync client with success, but with the new client I get the same error, "Sorry, OneDrive can’t add your folder right now." The problem is not related to my computer, as I have used other computers and get the same error. The problem is not with licensing as far as I can tell: All of my co-workers have OD4B, and as I said, I had it in the past. Most collection/site features are turned off. However, I am unable to deactivate the Document Sets feature (I get a "Cannot deactivate the feature because the Document Set content type is in use." error message, and am unable to locate where the Document Set content type is in use--if it really is). Could this be the cause? I have run the issue past several others in my organization to admin O365 issues, and they're unable to diagnose the problem. Any help would be appreciated!
    • Anonymous
      March 30, 2017
      The article has been updated. Please check to see if the additions resolve issue for you.
  • Anonymous
    March 15, 2017
    Ah, I am able to get OneDrive sync client to work if I'm using an older version. 16.0.7571.2109 works just fine. Whazzup?
    • Anonymous
      March 30, 2017
      The article has been updated. Please check to see if the additions resolve issue for you.
  • Anonymous
    March 23, 2017
    I'm using higher version of OneDrive, and "Require Check Out" setting is already "No", but I see exactly same error message yet. And I tried to login another PC which is working OK with my colleague's ID, but I faced same error message using my ID.Are there anything else to check ?
    • Anonymous
      March 30, 2017
      The article has been updated. Please check to see if the additions resolve issue for you.