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Support-Tip: (SYNC): Unable to connect to the Synchronization Service" error when you attempt to open the MIISCLIENT.EXE

APPLIES TO

  • Forefront Identity Manager 2010 Synchronization Server / R2 / R2 SP1
  • Microsoft Identity Manager 2016 / 2016 SP1
  • Azure AD Connect Sync

 

PROBLEM SCENARIO DESCRIPTION

You attempt to launch the Synchronization Service Manager Console either by clicking on the icon on the Start Menu or by attempting to launch the MIISCLIENT.EXE and you receive the following dialog

syncclientnotstart

 

CAUSE

There are a few causes to this some of which are documented on the dialog itself

  1. The logged on user is not part of the correct Synchronization Service Group

 

NOTE Here is more information on the Security Groups:

 

  1. The Forefront Identity Manager Synchronization Service is not started.

 

NOTE Here are the names of the service based on the product.
  • Azure AD Connect = Microsoft Azure AD Sync
  • Forefront Identity Manager = Forefront Identity Manager Synchronization Service
  • Microsoft Identity Manager = Forefront Identity Manager Synchronization Service

 

RESOLUTION

Ensure the Synchronization Service is started
In Administrative Tools double click on Services Locate the Sync Service to the Product that you are working with here Ensure that the Sync Service is Started

 

Add logged on account to the proper security group based on the logged on user needs to do
NOTE Here is more information on the Security Groups: Support-Info: (AADCONNECT): Azure AD Connect Sync Security Groups: https://blogs.technet.microsoft.com/iamsupport/2017/03/21/support-info-azure-ad-connect-sync-security-groups/ Forefront Identity Manager Security Groups: https://technet.microsoft.com/en-us/library/jj590183(v=ws.10).aspx
 Open the Security Group and add the member to the group

 

Verify the connectivity to the backend database
One way you can do this is through a UDL file.  Here is how to create a UDL File to test SQL Connectivity:How to create a UDL file to test the connection to SQL Server
  1. Create a new text file on the Desktop and call it TestSQL.Txt
  2. Change the file extension to UDL (TestSQL.UDL)
  3. Open a Command-Prompt where you right click while holding the Shift button down to select Run As.
    1. You want to run it as the FIM Service Management Agent Account
    2. Or you could log into the machine as the FIM Service Management Agent Account
  4. Double click on the TestSQL.UDL
  5. On the Provider Tab ensure that Microsoft OLE DB Provider for SQL Server is selected
  6. Click Next
  7. On the Connection Tab,
    1. Select or enter a server name: Enter the name of the SQL Server that the Synchronization Service is pointing which is housing the FIMSynchronizationService database.
    2. Use Windows NT Integrated Security
    3. Click Test Connection
  8. If this works, then you have a successful connection to SQL Server

 

ADDITONAL RESOURCES / INFORMATION

 

DOCUMENTATION