Toolbar is missing within the Dynamics CRM 4.0 Outlook Client
Symptom
CRM toolbar is not visible even after configuration is completed. Below is error message that we got from diagnostic tool.
Microsoft.Crm.Outlook.Diagnostics.WarningDiagnosticCheckException: You recently used a different Outlook profile than the one the Microsoft Dynamics CRM add-in has been configured for. The Microsoft Dynamics CRM add-in will be enabled only for the profile it was configured for. at Microsoft.Crm.Outlook.Diagnostics.OutlookProfileDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) at Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)
Cause
Customer is running CRM 4.0 and Outlook 2007 (both 32bit) on a 64bit machine.
After installing MS Project 2010 (32bit) + some MUI components (see additional components that got installed)
the following registry key gets added in the TypeLib section:
[HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.4]
"PrimaryInteropAssemblyName"="Microsoft.Office.Interop.Outlook, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C"
Resolution
Uninstalling MS Project 2010 on the affected machines (+ the related components that are added during the install. E.g. MUI)
or
Manually remove the regkey that was added during the MS Project 2010 installation (part of the additional components)
[HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}\9.4]
"PrimaryInteropAssemblyName"="Microsoft.Office.Interop.Outlook, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71E9BCE111E9429C"
Best Regards
Microsoft Dynamics CRM Support Team