次の方法で共有


Unknown Error trying to click on versions history in a document library

Issue:

====

If you receive "Unknown Error" when trying to view version history or set an alert on the item in the document library I did. And you try viewing the "View Properties" of the item in the document library it would redirect you to the main site’s home page.

Workaround:

==========

1. Open the "broken" DispForm.aspx for the Document Library named "documents" in Sharepoint Desinger.

2. Open a different Document Library's "working" DispForm.aspx

3. Copy the OOB List Form web part from the "working" DispForm.aspx (different library) to the "non-working" one.

4. Save the page and hit F12 to preview in browser.

5. Copy the ListID value from the Custom List Form on the broken DispForm.aspx and replaced it with the OOB List Form's "List Name" attribute; example: {GUID}

6. Save the page again and go to the Document Library and selected "View Properties"; it will direct to the DispForm.aspx page as expected.

7. The issue is resovled.

Cause:

=====

Accidental removal of the the OOB List Form web part, never remove the OOB List Form web part instead modify the Web Part Properties to "hide" and "close" the web part.

Comments

  • Anonymous
    May 19, 2009
    Thanks for the article.  This has helped me fix an issue where my Pages library was doing the exact same thing.   I did have problems figuring out your step 5.  We needed to engage SPDev support to figure it out. Here is how we found the ListID: -Select * from AllLists Where tp_title LIKE 'Pages%'. -Ran the query for the content DB that the site collection is in, there were four items in the results. So we need to choose which one is the broken Pages library. -Browse to the broke Pages library, click on Settings->Document Library Settings, in the address bar of the browser,see "http://servername/.../_layouts/listedit.aspx?List=%7B7FD....403%7D" -Compare "%7B7FD....403%7D" with the items in the SQL query results, you can identify the listID. -With the correct ListID, and follow the intructions in the blog.

  • Anonymous
    November 22, 2010
    That was exactly my issue and your directions worked perfect!