Condividi tramite


Risolvere gli errori di coda di esecuzione del flusso desktop

Questo articolo fornisce soluzioni in background e potenziali per gli errori basati su coda rilevati durante l'esecuzione del flusso desktop.

Si applica a: Power Automate
Numero KB originale: 5004537

Sintomi

L'esecuzione del flusso desktop potrebbe non riuscire con il codice NoCandidateMachine di errore o i dettagli dell'errore "Non è stato trovato alcun computer in grado di eseguire il flusso desktop".

È anche possibile ricevere uno di questi codici comuni di suberrore:

Causa

Quando non sono disponibili computer, Power Automate crea una coda per contenere i flussi desktop in attesa di essere eseguiti. Una volta disponibile un computer, l'esecuzione del flusso desktop successiva verrà selezionata per l'esecuzione in base alla priorità e al tempo di richiesta. Se non è disponibile alcun computer dopo sei ore dal momento in cui è stato richiesto, il flusso desktop si verifica il timeout e avrà esito negativo con un NoCandidateMachine codice di errore.

Come indicato nel messaggio di errore, questo errore indica che l'agente di orchestrazione non riesce a trovare un computer disponibile per eseguire il flusso desktop. Questo errore si verifica prima dell'avvio dell'esecuzione del flusso desktop.

Importante

Power Automate ridimensiona automaticamente il numero di esecuzioni simultanee del flusso desktop al valore massimo supportato. La coda di esecuzione del computer segue un approccio first-in first-out, il che significa che la prima esecuzione ricevuta è quella successiva da eseguire. Se tutti i computer disponibili hanno raggiunto il numero massimo di sessioni simultanee e non possono eseguire l'esecuzione successiva nella coda, la coda viene bloccata finché un computer non diventa disponibile per eseguire l'esecuzione successiva nella coda.

SessionExistsForTheUserWhenUnattended

Questo errore si verifica quando si tenta di eseguire un flusso desktop automatico in un computer di destinazione in cui l'utente usato nella connessione del flusso desktop è connesso.

Risoluzione

Per risolvere il problema, disconnettersi dalla sessione (una sessione bloccata genererà questo errore) e verificare di non aver eseguito l'accesso con lo stesso utente nel computer.

UnattendedUserSessionDisconnected

Questo errore si verifica quando si tenta di eseguire un flusso desktop automatico in un computer di destinazione in cui è presente una sessione disconnessa per l'utente usato nella connessione del flusso desktop.

Risoluzione

Per risolvere il problema, disconnettersi dalla sessione disconnessa e verificare di non aver eseguito l'accesso con lo stesso utente nel computer.

UnattendedUserSessionLocked

Questo errore si verifica quando si tenta di eseguire un flusso desktop automatico in un computer di destinazione in cui è presente una sessione bloccata per l'utente usato nella connessione del flusso desktop.

Risoluzione

Per risolvere il problema, disconnettersi dalla sessione bloccata e verificare di non aver eseguito l'accesso con lo stesso utente nel computer.

AttendedUserSessionNotActive

Questo errore si verifica quando si tenta di eseguire un flusso desktop operatore in un computer di destinazione in cui la sessione utente è bloccata o disconnessa. I flussi desktop interessati possono essere eseguiti solo se il computer viene sbloccato in una sessione in cui l'utente corrente corrisponde a quello nella connessione del flusso desktop.

Risoluzione

Per risolvere il problema,

  • Riconnettersi al computer con l'utente usato per l'esecuzione partecipata e consentire la sessione attiva nel computer.
  • Verificare di usare come destinazione il computer corretto. A tale scopo, aprire l'applicazione di runtime del computer e selezionare Visualizza computer nel portale per verificare che sia possibile accedere al computer di destinazione nell'esecuzione.

AttendedUserNotLoggedIn

Questo errore si verifica quando l'utente specificato nella connessione non ha eseguito l'accesso al computer di destinazione.

Risoluzione

Per risolvere il problema,

  • Connettersi al computer con l'utente usato per l'esecuzione partecipata e consentire la sessione attiva nel computer.
  • Verificare di usare come destinazione il computer corretto. A tale scopo, aprire l'applicazione di runtime del computer e selezionare Visualizza computer nel portale per verificare che sia possibile accedere al computer di destinazione nell'esecuzione.
  • Controllare le credenziali usate nella connessione e assicurarsi che siano quelle usate nella sessione sbloccata. È possibile verificare l'identità digitando whoami in qualsiasi prompt dei comandi.

Note

Per AttendedUserSessionNotActive o AttendedUserNotLoggedIn errori, verificare che l'account che esegue il servizio Power Automate (UIFlowService) disponga delle autorizzazioni Desktop remoto nel computer. Per impostazione predefinita, il servizio Power Automate viene eseguito come NT SERVICE\UIFlowService. Se l'operazione non è stata modificata, verificare che NT SERVICE\UIFlowService si trovi nel gruppo Utenti Desktop remoto. A tale scopo, passare a Avvia>esecuzione, digitare usrmgr.msc, selezionare Gruppi, fare doppio clic sul gruppo Utenti Desktop remoto e verificare che l'account sia incluso. Se non è incluso, includerlo (richiede autorizzazioni di amministratore) e riavviare il computer.

UIFlowAlreadyRunning

Quando un flusso desktop è già in esecuzione nel computer, questo errore può verificarsi in una delle situazioni seguenti:

  • Si esegue un flusso desktop operatore o automatico e il numero di sessioni attive nel computer ha raggiunto il limite.
  • Si tenta di aprire una sessione per un utente che ha già eseguito l'accesso.

Risoluzione

Per risolvere il problema, attendere il completamento dei flussi già in esecuzione o annullare l'esecuzione del flusso cloud padre.

Altri codici di errore

Per informazioni su altri codici di errore che possono verificarsi durante l'esecuzione di flussi desktop e passaggi per attenuare i problemi, vedere Codice di errore durante l'esecuzione di un flusso desktop automatico o operatore.

Ulteriori informazioni

Se il codice di suberrore non viene specificato, verificare se:

  • Il computer o tutti i computer nel gruppo di computer sono offline.

    Avviare il computer e assicurarsi che Power Automate Desktop sia installato correttamente e possa comunicare con Internet.

  • Il gruppo di computer è vuoto.

    Assicurarsi che il gruppo di computer contenga almeno un computer prima di assegnarlo a un'esecuzione del flusso desktop.

  • Il computer o tutti i computer del gruppo di computer sono continuamente occupati.

    Se i computer non prelevano il flusso desktop in tempo, è probabile che le risorse del computer allocate non siano sufficientemente scalabili per soddisfare la domanda del flusso di lavoro. L'aggiunta di altri computer potrebbe aiutare a distribuire il carico di lavoro.

  • Il computer non può essere raggiunto a causa di problemi di rete (incluso il proxy o il firewall).

    Collaborare con l'amministratore IT per assicurarsi che i computer siano raggiungibili.

  • Il problema è temporaneo.

    Provare a modificare i criteri di ripetizione dei tentativi nelle impostazioni delle azioni.

  • Il computer o tutti i computer nel gruppo di computer non sono in grado di connettersi con il flusso desktop.

    Assicurarsi che venga soddisfatta una delle condizioni seguenti:

    • Non si sta tentando di eseguire un flusso automatico in un gruppo in cui sono connessi tutti i computer.
    • Non si sta tentando di eseguire un flusso operatore in un gruppo in cui sono disconnessi tutti i computer.
  • La macchina non è più utilizzabile.

    Aggiungere un nuovo computer, quindi aggiornare le connessioni del flusso desktop nei flussi cloud per usare il nuovo computer.

Se si dispone di un backup dei flussi desktop nella coda di esecuzione a causa di uno dei motivi precedenti, è possibile annullare in blocco le esecuzioni del flusso desktop annullando l'esecuzione del flusso cloud padre usando l'azione Annulla esecuzione flusso padre nella pagina Esecuzioni flusso desktop. Dopo aver risolto il problema del computer, è possibile riavviare i flussi cloud.