L'errore "Attributo PrimaryName non trovato per l'entità" si verifica durante l'importazione della soluzione
Questo articolo fornisce una soluzione alternativa per un errore che si verifica quando si importa una soluzione in Power Apps.
Si applica a: Power Platform, Soluzioni
Sintomi
Quando si importa una soluzione, viene visualizzato il messaggio di errore seguente:
L'attributo PrimaryName non è stato trovato per Entità
Causa
Questo errore si verifica quando l'attributo del nome primario di una tabella non è incluso nel file di .xml della soluzione.
Soluzione alternativa
Per risolvere il problema, seguire questa procedura:
- Rimuovere la tabella dalla soluzione nell'ambiente di origine.
- Aggiungere nuovamente la tabella e tutti gli asset all'ambiente di origine per assicurarsi che siano inclusi i metadati necessari.
- Esportare la soluzione e importarla nuovamente nell'ambiente di destinazione.