I record di Dataverse vengono creati senza campi obbligatori
Si applica a: Dynamics 365 Field Service, Dataverse
Sintomi
Dopo che gli utenti inseriscono i dati tramite l'API Web Microsoft Dataverse, alcuni campi obbligatori mancano o non vengono popolati nei record creati. Ad esempio, il campo Titolo caso obbligatorio è vuoto in un caso creato, come illustrato nello screenshot seguente.
Quando si apre il caso interessato, è necessario immettere un valore per il campo Titolo maiuscole/minuscole.
Causa
Questo problema si verifica se i record vengono creati da uno strumento di terze parti, ad esempio Postman. Questi strumenti non controllano i campi obbligatori. Invece, inviano i dati così come sono.
Soluzione alternativa
Per risolvere questo problema, assicurarsi di controllare gli elementi seguenti:
- Verificare che i campi obbligatori siano inclusi nei flussi.
- Verificare l'esistenza di campi obbligatori nelle entità create tramite richieste HTTP.