Condividi tramite


Un computer client può rubare il GUID di Configuration Manager di un oggetto Computer sconosciuto durante l'immagine

Questo articolo fornisce le informazioni per risolvere il problema che l'identificatore univoco di Configuration Manager (GUID) di un oggetto Computer sconosciuto viene acquisito da un computer client che viene immagineto.

Versione originale del prodotto: Configuration Manager (Current Branch)
Numero KB originale: 4471061

Sintomi

Configuration Manager Current Branch versione 1702 includeva una nuova funzionalità che consente di usare il pulsante Indietro per riprovare una sequenza di attività non riuscita nella Creazione guidata sequenza di attività quando viene eseguita in Ambiente preinstallazione di Microsoft Windows (Windows PE).

Per altre informazioni su questa funzionalità, vedere Tornare alla pagina precedente in caso di errore di una sequenza di attività.

Questa funzionalità ha introdotto il problema seguente:

Quando si seleziona il pulsante Indietro , il PC client che viene immagine può rubare l'identificatore univoco (GUID) di Configuration Manager dell'oggetto Computer sconosciuto in uso (computer sconosciuto x64 o computer sconosciuto x86).

Questo problema è stato risolto nell'aggiornamento cumulativo per Configuration Manager Current Branch versione 1702.

Questo problema è stato risolto anche in tutte le versioni successive di Configuration Manager Current Branch.

Tuttavia, a partire da Configuration Manager Current Branch versione 1702, i computer sconosciuti avviati dall'ambiente di esecuzione del supporto o di preavvio (PXE) potrebbero non trovare sequenze di attività destinate a tali computer. In questo scenario viene registrato il messaggio di errore seguente nel SMSTS.log:

Nessuna sequenza di attività disponibile per il computer. Assicurarsi di avere almeno una sequenza di attività pubblicizzata al computer.

Errore non specificato (errore: 80004005; Origine: Windows)

Questo problema può verificarsi se nel computer sconosciuto è selezionato il pulsante Indietro nella pagina Seleziona una sequenza di attività da eseguire .

Questo problema è stato risolto anche in tutte le versioni successive di Configuration Manager Current Branch.

Nonostante l'applicazione dell'aggiornamento cumulativo in Configuration Manager Current Branch versione 1702 o l'aggiornamento a una versione successiva di Configuration Manager, il problema si verifica ancora.

Causa

Questo problema può continuare a verificarsi perché la correzione nell'aggiornamento cumulativo per Configuration Manager Current Branch versione 1702 e versioni successive di Configuration Manager Current Branch impedisce che il problema si verifichi solo in futuro. Non risolve il problema se il problema esiste attualmente nell'ambiente.

Di conseguenza, il problema può continuare a verificarsi in Configuration Manager Current Branch versione 1702 o successiva anche dopo l'applicazione dell'aggiornamento cumulativo della versione 1702 o successiva. Questo vale a meno che non vengano eseguiti i passaggi seguenti:

  • Aggiornare le immagini d'avvio nei punti di distribuzione.
  • Ricreare il supporto di avvio usando le immagini aggiornate.
  • Pulire correttamente il PC client che ha rubato il GUID.

Risoluzione

Avviso

Non provare a risolvere questo problema ricreando gli oggetti Computer sconosciuti. Questo problema non risolve correttamente il problema e non impedisce la ripetizione del problema. Inoltre, esistono problemi noti che si verificano in ambienti con più oggetti Computer sconosciuti per un singolo sito. Se in precedenza si è tentato di risolvere questo problema ricreando gli oggetti Computer sconosciuti, vedere Rimuovere oggetti computer sconosciuti duplicati.

Per risolvere questo problema e impedirne la restituzione nell'ambiente, seguire questa procedura:

  1. Aggiornare tutte le immagini d'avvio nell'ambiente. A tale scopo, fare clic con il pulsante destro del mouse sulle immagini nella console di Configuration Manager e quindi scegliere Aggiorna punti di distribuzione. In questo modo i file binari aggiornati di Configuration Manager che contengono la correzione nell'immagine di avvio. Per altre informazioni, vedere Aggiornare i punti di distribuzione con l'immagine di avvio.

  2. Se si usano supporti nell'ambiente, ricreare tutti i supporti nell'ambiente dopo aver aggiornato tutte le immagini di avvio nei punti di distribuzione. Ciò garantisce che le immagini di avvio aggiornate con la correzione si trovino nel supporto usato nell'ambiente.

    Per impedire l'uso di file multimediali con immagini di avvio precedenti, i certificati per tali immagini di avvio possono essere bloccati nella console di Configuration Manager nel nodo Administration Security Certificates (Certificati di sicurezza di amministrazione>>). Per assicurarsi che il problema non si verifichi nuovamente, è consigliabile bloccare tutti i certificati per tutti i supporti creati prima che le immagini di avvio siano state aggiornate nel passaggio 1. La data in cui è stato creato il supporto viene visualizzata nella colonna Data di inizio.

    Per altre informazioni su come creare supporti, vedere Creare supporti della sequenza di attività.

  3. Il computer client che ha rubato il GUID deve essere pulito correttamente.

Per pulire correttamente il client che ha rubato il GUID, seguire questa procedura:

  1. Identificare il computer che ha acquisito il GUID. A tale scopo, esaminare le proprietà dell'oggetto Computer sconosciuto (in genere computer sconosciuto x64), prendere nota del valore di Identificatore univoco di Configuration Manager e quindi eseguire una query nella console di Configuration Manager per identificare l'oggetto computer con lo stesso GUID. È possibile eseguire tutti questi passaggi dalla console. Non è necessario accedere al database di SQL Server per eseguire questa operazione.

  2. Dopo aver identificato il computer che ha acquisito il GUID rubato, connettersi in remoto a tale computer e quindi pulire completamente il client di Configuration Manager. Questo comporta più che semplicemente disinstallare il client. È invece necessario seguire i passaggi da 3 a 7.

  3. Nel computer client, in C:\Windows\CCMSetup, eseguire il CCMSetup.exe /uninstall comando al prompt dei comandi con privilegi elevati.

  4. Monitorare Gestione attività fino al termine dell'esecuzione di CCMSetup. Controllare il file ccmsetup.log per assicurarsi che il client sia stato disinstallato correttamente.

  5. Nel computer client eliminare le directory seguenti:

    • C:\Windows\CCM
    • C:\Windows\CCMSetup

    Note

    Per eliminare completamente queste directory, potrebbe essere necessario riavviare il computer.

  6. Nel computer client eliminare le chiavi del Registro di sistema seguenti (se esistenti):

    • HKEY_LOCAL_MACHINE\Software\Microsoft\CCM
    • HKEY_LOCAL_MACHINE\Software\Microsoft\CCMSetup
    • HKEY_LOCAL_MACHINE\Software\Microsoft\SMS
  7. Nel computer client eliminare il file C:\Windows\SMSCFG.ini.

  8. Nel computer client eliminare tutti i certificati nel nodo Certificati SMS>nella console Certificati per l'account computer. A tale scopo, effettuare i passaggi seguenti:

    1. Eseguire MMC.exe al prompt dei comandi con privilegi elevati.

    2. Nel menu File, selezionare Aggiungi/Rimuovi snap-in.

    3. Selezionare Certificati e quindi Aggiungi.

    4. Selezionare Account computer e quindi Avanti.

    5. Selezionare Computer locale e quindi Fine.

    6. Seleziona OK.

    7. Passare a Certificati SMS>Certificati>.

    8. Nel riquadro dei risultati fare clic con il pulsante destro del mouse su ogni certificato elencato nel nodo Certificati> SMS>e quindi scegliere Elimina. Ripetere questo passaggio fino a quando non vengono eliminati tutti i certificati.

    9. Chiudere la console Certificati .

  9. Eliminare il record del computer che causa l'errore dalla console di Configuration Manager. Anche in questo caso, non è necessario accedere al database di SQL Server per eseguire questa operazione. È possibile eliminare il record dalla console di Configuration Manager. Assicurarsi di eseguire questa operazione dopo aver completato i passaggi da 1 a 8. In questo modo, è possibile che il record venga ricreato se viene eseguito il backup dei report del client prima che vengano completamente puliti.

  10. Reinstallare il client di Configuration Manager nel computer client che causa l'errore.

Rimuovere oggetti computer sconosciuti duplicati

Se gli oggetti Computer sconosciuti sono stati ricreati nel sito quando si tenta di risolvere il problema, è necessario eliminare gli oggetti Computer sconosciuti aggiuntivi. A tale scopo, tutti gli oggetti Computer sconosciuti correnti devono essere eliminati per il sito interessato seguito dalla creazione di un nuovo set di oggetti Computer sconosciuti per il sito. L'eliminazione di oggetti Computer sconosciuti può essere completata solo dal database di SQL Server. Non è possibile eseguire questa operazione dalla console di Configuration Manager.

Note

È accettabile avere più oggetti Computer sconosciuti se sono presenti più siti primari. Tuttavia, ogni sito deve avere un solo oggetto Computer sconosciuto per ogni architettura. Ad esempio, deve essere presente un solo oggetto x64 con etichetta x64 Unknown Computer e un solo oggetto x86 con etichetta x86 Unknown Computer.

Per eliminare gli oggetti Computer sconosciuti aggiuntivi, seguire questa procedura:

  1. Assicurarsi di disporre di un backup corrente e valido del sito di Configuration Manager usando l'attività di manutenzione backup predefinita.

  2. Aprire la console di Service Manager. Se sono presenti più siti primari, è consigliabile aprire una console di Configuration Manager connessa al sito di amministrazione centrale.

  3. Nella console di Configuration Manager passare a Asset e conformità>Panoramica>raccolte di dispositivi.

  4. Fare doppio clic sull'insieme Tutti i computer sconosciuti.

  5. Nel riquadro dei risultati ordinare gli oggetti nell'insieme Tutti i computer sconosciuti selezionando la colonna Codice sito.

  6. Si noti se sono presenti più oggetti Computer sconosciuti x64 o oggetti computer sconosciuti x86 per qualsiasi singolo sito.

  7. Se sono presenti più oggetti Computer sconosciuti x64 o oggetti Computer sconosciuti x86 per un singolo sito, fare clic con il pulsante destro del mouse sulle colonne nel riquadro dei risultati e aggiungere l'ID risorsa all'elenco di colonne.

  8. Determinare il valore id risorsa per ogni oggetto computer sconosciuto x64 e ogni oggetto computer sconosciuto x86 per un sito. Assicurarsi di annotare l'ID risorsa per tutti gli oggetti Computer sconosciuti anche se viene duplicato solo uno degli oggetti Computer sconosciuti.

  9. Dopo aver determinato gli ID risorsa degli oggetti Computer sconosciuti per un sito, è possibile eliminare gli oggetti Computer sconosciuti x64 e gli oggetti Computer sconosciuti x86 per il sito.

  10. Aprire SQL Server Management Studio e quindi connettersi al database per il sito che ospita gli oggetti Computer sconosciuti aggiuntivi.

  11. Espandere il nodo Database e selezionare il database di Configuration Manager (in genere CM_Site_Code).

  12. Nella barra degli strumenti selezionare Nuova query.

  13. Assicurarsi che il database corretto sia selezionato nel menu a discesa a sinistra del pulsante Esegui sulla barra degli strumenti.

  14. Nel riquadro query eseguire la query SQL seguente:

    SELECT C.CollectionID, C.SiteID, C.CollectionName, CM.MachineID, CM.Name FROM Collections C JOIN CollectionMembers CM ON C.SiteID = CM.SiteID JOIN UnknownSystem_DISC USD ON USD.ItemKey = CM.MachineID
    

    Questa query visualizza tutte le raccolte a cui appartengono tutti gli oggetti Computer sconosciuti. Utilizzare questa query per determinare quali raccolte gli oggetti Computer sconosciuti sono membri di . Prendere nota di queste informazioni in modo che, quando viene creato il nuovo set di oggetti Computer sconosciuti, è possibile aggiungerle nuovamente alle raccolte appropriate. L'ID risorsa è elencato nella colonna MachineID.

  15. Nel riquadro query eseguire la query SQL seguente:

    SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
    

    In questa query è Resource_ID_x l'ID risorsa di ognuno degli oggetti Computer sconosciuti per il sito, come determinato nel passaggio 9. Ad esempio, se gli ID risorsa sono 2046820354 e 2046820355, la query sarà la seguente:

    SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354','2046820355')
    
  16. Verificare che i record restituiti dalla query nel passaggio 15 siano corretti. In caso affermativo, eseguire la query seguente per eliminare i record:

    DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
    

    In questa query è Resource_ID_x l'ID risorsa di ognuno degli oggetti Computer sconosciuti per il sito, come determinato nel passaggio 9. Ad esempio, se gli ID risorsa sono 2046820354 e 2046820355, la query di eliminazione sarà la seguente:

    DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354', '2046820355')
    

    Note

    Ricordarsi di eliminare tutti gli oggetti Computer sconosciuti per il sito interessato, sia x64 che x86, anche se solo uno di essi è stato duplicato.

  17. Seguire la sezione Ricreare oggetti computer sconosciuti in caso di eliminazione accidentale per creare nuovi oggetti Computer sconosciuti per il sito interessato.

  18. Tornare alla console di Configuration Manager e quindi passare a Asset e conformità>Panoramica>raccolte di dispositivi.

  19. Fare clic con il pulsante destro del mouse sull'insieme Tutti i computer sconosciuti e quindi scegliere Aggiorna appartenenza.

  20. Attendere alcuni minuti e quindi selezionare Aggiorna. Verificare che esista un solo oggetto Computer sconosciuto x64 o un oggetto Computer sconosciuto x86 per ogni sito. Se gli oggetti non vengono visualizzati, attendere alcuni minuti e riprovare.

  21. Una volta visualizzati i nuovi oggetti Computer sconosciuti, aggiungerli di nuovo alle raccolte appropriate, come determinato nel passaggio 14.

  22. Ripetere i passaggi da 10 a 21 per tutti i siti primari aggiuntivi, se necessario.

Ricreare oggetti Computer sconosciuti in caso di eliminazione accidentale

Se, per qualsiasi motivo, tutti gli oggetti Computer sconosciuti vengono eliminati accidentalmente per qualsiasi sito che utilizza questo processo, possono essere ricreati seguendo questa procedura. Questi passaggi devono essere eseguiti solo se non sono presenti oggetti Computer sconosciuti per un sito. Se in un sito sono presenti solo uno dei due oggetti Computer sconosciuti, eliminare l'oggetto computer sconosciuto rimanente seguendo la procedura descritta nella sezione Rimuovere oggetti computer sconosciuti duplicati di questo articolo e seguire questa procedura:

  1. Accedere al server del sito primario da cui mancano gli oggetti Computer sconosciuti.

  2. A un prompt dei comandi con privilegi elevati, eseguire il comando seguente:

    REG.exe ADD "HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_DISCOVERY_DATA_MANAGER" /v CreatedUnknownDDR /t REG_DWORD /d 0 /f
    

Dopo l'aggiornamento del valore della chiave del Registro di sistema, gli oggetti Computer sconosciuti devono essere ricreati automaticamente subito dopo. È possibile controllare lo stato di avanzamento della creazione degli oggetti Computer sconosciuti nel file DDM.log nel server del sito primario.

Per velocizzare la ricreazione dei record computer sconosciuti, riavviare il SMS_DISCOVERY_DATA_MANAGER thread seguendo questa procedura:

  1. Aprire la console di Configuration Manager nel sito primario da cui mancano gli oggetti Computer sconosciuti e quindi passare a Monitoraggio dello>>stato del componente stato>del sistema.

  2. Sulla barra degli strumenti selezionare Avvia>Configuration Manager Service Manager.

  3. In Configuration Manager Service Manager espandere il nodo sotto il codice del sito e quindi selezionare Componenti.

  4. Nel riquadro dei risultati fare clic con il pulsante destro del mouse SMS_DISCOVERY_DATA_MANAGER e scegliere Query. Il thread deve essere visualizzato come In esecuzione.

  5. Fare clic con il pulsante destro del mouse su SMS_DISCOVERY_DATA_MANAGER, quindi scegliere Arresta.

  6. Fare clic con il pulsante destro del mouse su SMS_DISCOVERY_DATA_MANAGER, quindi scegliere Query.

    Note

    Il thread deve essere visualizzato come Arrestato.

  7. Fare clic con il pulsante destro del mouse su SMS_DISCOVERY_DATA_MANAGER, quindi scegliere Avvia.

  8. Fare clic con il pulsante destro del mouse su SMS_DISCOVERY_DATA_MANAGER, quindi scegliere Query.

    Note

    Il thread deve essere visualizzato come In esecuzione.

  9. Chiudere la finestra di Configuration Manager Service Manager .

Gli oggetti Computer sconosciuti devono essere ricreati automaticamente a breve. È possibile controllare lo stato di avanzamento di questo processo nel file DDM.log nel server del sito primario.