L'invio con winhttp non è riuscito 80072f8f errore in Smsts.log durante la distribuzione del sistema operativo usando supporti di avvio o pre-installazione
Questo articolo consente di risolvere un problema in cui la Creazione guidata sequenza di attività restituisce l'errore 80004005 e Smsts.log registra l'errore Invio con winhttp non riuscito; errore 80072f8f durante una distribuzione del sistema operativo che usa supporti di avvio o pre-installazione.
Versione originale del prodotto: Configuration Manager (Current Branch), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Numero KB originale: 4551033
Sintomi
È possibile creare supporti di avvio o supporti pre-installati in Configuration Manager. Quando il supporto viene utilizzato per avviare il computer di destinazione, la Creazione guidata sequenza di attività viene bloccata nei criteri di recupero per questo passaggio del computer per circa 90 secondi, quindi restituisce il messaggio di errore seguente:
Impossibile eseguire la sequenza di attività
Errore durante il recupero dei criteri per il computer (0x80004005). Per altre informazioni, contattare l'amministratore di sistema o l'operatore helpdesk.
I messaggi di errore seguenti vengono registrati in X:\Windows\Temp\SMSTSLog\smsts.log nel computer quando il motore della sequenza di attività tenta prima di tutto di contattare il punto di gestione per sincronizzare le informazioni sull'ora:
TSMBootstrap Informazioni sull'ora corrente:
TSMBootstrap Ottenere informazioni sull'ora mp
TSMBootstrap Che richiede l'identità client
TSMBootstrap Impostazione dell'autenticatore.
TSMBootstrap CLibSMSMessageWinHttpTransport::Send: WinHttpOpenRequest - URL: <MP>:443 CCM_POST /ccm_system_AltAuth/request
TSMBootstrap SSL, usando l'autenticatore nella richiesta.
TSMBootstrap in SSL, ma senza certificato client.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE rilevato
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength è 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation è 0x8
TSMBootstrap [TSMESSAGING] : WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA è impostato
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
Errore TSMBootstrap. Ricevuto 0x80072f8f da WinHttpSendRequest.
TSMBootstrap Invio con winhttp non riuscito; 80072f8f. Riprovare.
TSMBootstrap Riprova e ignora gli errori di sicurezza della data.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE rilevato
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength è 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation è 0x8
TSMBootstrap [TSMESSAGING] : WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA è impostato
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap hr, HRESULT=80072f8f
TSMBootstrap Invio con winhttp non riuscito; 80072f8f
Dopo l'errore iniziale, il motore della sequenza di attività tenta quattro volte di contattare il punto di gestione ed esegue una pausa crescente tra ogni tentativo. Tuttavia, tutti i tentativi hanno esito negativo e restituiscono gli stessi messaggi di errore prima che vengano restituiti alcuni messaggi di errore finali, come indicato di seguito:
Se il supporto è configurato come supporto dinamico, vengono registrati i messaggi di errore finali seguenti Smsts.log:
TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
TSMBootstrap non è riuscito a inviare la richiesta
TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
TSMBootstrap non è riuscito a ottenere l'identità client (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
TSMBootstrap non è riuscito a richiedere il client
TSMBootstrap SyncTimeWithMP() non è riuscito. 80072f8f.
TSMBootstrap Non è stato possibile ottenere informazioni sull'ora da MP:https://<MP>
.
TSMBootstrap MpCnt > 0, HRESULT=80004005
TSMBootstrap QueryMPLocator: non vengono ricevuti percorsi MP validi
TSMBootstrap TSMBootstrapUtil::QueryMPLocator ( true, sSMSTSLocationMPs.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, httpS, http, accessibleMpCnt), HRESULT=80004005
TSMBootstrap non è riuscito a eseguire query sul localizzatore del punto di gestione
TSMBootstrap uscita da TSMediaWizardControl::GetPolicy.
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
Errore dell'impostazione guidata TSMBootstrap: si è verificato un errore durante il recupero dei criteri per il computer (0x80004005). Per altre informazioni, contattare l'amministratore di sistema o l'operatore helpdesk.Se il supporto è configurato come basato sul sito, vengono registrati i messaggi di errore finali seguenti Smsts.log:
TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
TSMBootstrap non è riuscito a inviare la richiesta
TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
TSMBootstrap non è riuscito a ottenere l'identità client (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
TSMBootstrap non è riuscito a richiedere il client
TSMBootstrap SyncTimeWithMP() non è riuscito. 80072f8f.
TSMBootstrap Non è stato possibile ottenere informazioni sull'ora da MP:https://<MP>
.
TSMBootstrap sMP.length() > 0, HRESULT=80004005
TSMBootstrap TSMBootstrapUtil::SelectMP ( sSMSTSMP.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, sSiteCode, sAssignedSiteCode, sMP, sCertificates, sX86UnknownMachineGUID, sX64UnknownMachineGUID), HRESULT=80004005
TSMBootstrap Non è stato possibile selezionare MP
TSMBootstrap uscita da TSMediaWizardControl::GetPolicy.
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
Errore dell'impostazione guidata TSMBootstrap: si è verificato un errore durante il recupero dei criteri per il computer (0x80004005). Per altre informazioni, contattare l'amministratore di sistema o l'operatore helpdesk.
Le informazioni dettagliate seguenti si applicano all'errore 80072F8F:
Codice errore: 0x80072F8F (2147954575)
Nome errore: WININET_E_DECODING_FAILED
Origine errore: Windows
Messaggio di errore: la decodifica del contenuto non è riuscita
Causa
Questo problema si verifica se le seguenti condizioni sono vere:
- L'infrastruttura a chiave pubblica viene usata nell'ambiente di Configuration Manager.
- È possibile creare il supporto di avvio o il supporto pre-installato nel sito di amministrazione centrale.
- Configurare i punti di gestione per l'uso di HTTPS.
Se si usa l'infrastruttura a chiave pubblica nell'ambiente di Configuration Manager, l'autorità di certificazione radice (CA) viene specificata nel sito primario ma non nel sito di amministrazione centrale. Poiché il sito di amministrazione centrale non dispone delle informazioni della CA radice, il supporto creato non contiene le informazioni della CA radice. Di conseguenza, le richieste inviate a un punto di gestione abilitato per HTTPS hanno esito negativo senza le informazioni della CA radice.
Risoluzione
Per risolvere il problema, creare il supporto di avvio o il supporto pre-installato in un sito primario anziché nel sito di amministrazione centrale.
Ulteriori informazioni
Per i supporti che verranno usati in più siti, configurare i supporti come supporti dinamici. È possibile creare supporti dinamici in qualsiasi sito. Non è possibile limitarsi alla creazione nel sito di amministrazione centrale.