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Errore AADSTS50011 con l'autenticazione OpenID: l'URI di reindirizzamento specificato nella richiesta non corrisponde

Questo articolo descrive un problema in cui viene restituito un messaggio di errore AADSTS50011 quando si tenta di accedere a un'applicazione che utilizza l'autenticazione basata su OpenID Connect (OIDC) con Microsoft Entra ID.

Sintomi

Quando si tenta di accedere a un'applicazione che usa protocolli di autenticazione OIDC o OAuth2 con Microsoft Entra ID, viene visualizzato il messaggio di errore seguente:

Errore AADSTS50011: URI di reindirizzamento <URI di reindirizzamento> specificato nella richiesta non corrisponde agli URI di reindirizzamento configurati per l'applicazione <AppGUID>. Verificare che l'URI di reindirizzamento inviato nella richiesta corrisponda a quello aggiunto all'applicazione nel portale di Azure. Andare su https://aka.ms/redirectUriMismatchError per maggiori informazioni su come risolvere questo problema.

Causa

Questo errore si verifica se l'URI di reindirizzamento (URL di risposta) configurato nell'applicazione (codice) e la registrazione dell'applicazione Microsoft Entra non corrispondono.

Quando un utente accede all'applicazione per l'autenticazione, l'applicazione reindirizza l'utente a Microsoft Entra ID con un URI di reindirizzamento predefinito. Una volta che l'utente è stato autorizzato correttamente, Microsoft Entra ID verifica i seguenti valori:

  • URI di reindirizzamento inviato dall'applicazione
  • I valori dell'URI di reindirizzamento nell'applicazione registrata in Microsoft Entra ID

Se l'URI di reindirizzamento inviato dall'applicazione non corrisponde a nessuno degli URI di reindirizzamento in Microsoft Entra ID, verrà restituito l'errore AADSTS50011. Se i valori corrispondono, Microsoft Entra ID invia l'utente all'URI di reindirizzamento.

Risoluzione

Per risolvere il problema, seguire questi passaggi per aggiungere l'URI di reindirizzamento nella registrazione delle app di Microsoft Entra ID.

  1. Copiare l'ID dell'applicazione dal messaggio di errore. È l'ID dell'applicazione registrata in Microsoft Entra ID. Screenshot dell'ID dell'applicazione nel messaggio di errore AADSTS50011

  2. Vai al portale di Azure. Assicurarsi di accedere al portale utilizzando un account che disponga delle autorizzazioni per aggiornare la registrazione delle applicazioni Microsoft Entra.

  3. Passare a Microsoft Entra ID, selezionare Registrazioni app, individuare la registrazione dell'applicazione utilizzando l'ID dell'applicazione e aprire la pagina di registrazione dell'applicazione.

    È inoltre possibile aprire direttamente la pagina utilizzando i seguenti link:

    • Se l'app è di proprietà di un'organizzazione (tenant di Microsoft Entra), utilizzare https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationMenuBlade/Authentication/appId/<AppGUID>.
    • Se l'app è di proprietà dell'account Microsoft (MSA) personale, utilizzare https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationMenuBlade/Authentication/appId/<AppGUID>/isMSAApp/true.
  4. Nella pagina di registrazione dell'app, selezionare Autenticazione. Nella sezione Configurazioni piattaforma, selezionare Aggiungi URI per aggiungere l'URI di reindirizzamento visualizzato nel messaggio di errore a Microsoft Entra ID.

    Screenshot sull'URI di reindirizzamento nel messaggio di errore AADSTS50011

  5. Salvare le modifiche e attendere qualche minuto affinché le modifiche abbiano effetto, quindi inviare nuovamente la richiesta di accesso. A questo punto dovrebbe essere possibile accedere all'applicazione. Se non si riesce a visualizzare la pagina di accesso a Microsoft Entra, provare a cancellare la cache delle password dal browser o a utilizzare la navigazione InPrivate.

Note

Se l'URI di reindirizzamento inviato dall'applicazione non è quello desiderato, è necessario aggiornare il codice o la configurazione dell'applicazione.

Il video seguente mostra come correggere l'errore di mancata corrispondenza dell'URI di reindirizzamento in Microsoft Entra ID:

Ulteriori informazioni

Per un elenco completo dei codici di errore di autenticazione e autorizzazione di Active Directory, consultare Codici di errore di autenticazione e di autorizzazione di Microsoft Entra.

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