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Errore 400 o 401 quando si imposta la visibilità della tabella virtuale Dataverse

Codice errore: SYS81183

Questo articolo descrive i codici di errore (400 e 401) che possono verificarsi quando si imposta la visibilità della tabella virtuale Di Microsoft Dataverse per il servizio di calcolo fiscale in un ambiente RCS (Regulatory Configuration Service). Spiega anche cosa causa i problemi e come risolverli.

Note

Questo articolo è applicabile alla versione 10.0.38 o precedente.

Errore 400 con "InternalServerError"

Sintomi

Quando si imposta la visibilità della tabella virtuale o si esegue la ricerca dei dati master nella configurazione delle funzionalità fiscali, viene visualizzato il messaggio di errore seguente:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (400) Richiesta non valida. 0x80048d0b: è stato ottenuto un token per chiamare Finance and Operations, ma Finance and Operations ha restituito un errore di tipo InternalServerError.

Causa

Questo problema si verifica se il servizio finanziario e operativo è inattivo o se l'URL di destinazione finanza e operazioni non è impostato correttamente.

Risoluzione

  1. Verificare di poter accedere alle app finanziarie e operative usando lo stesso account usato per accedere a Dataverse.
  2. Passare a Dataverse>Advanced settings>Administration Virtual Entity Data Sources (Amministrazione>origini dati entità virtuali) e selezionare l'origine dati denominata finance and operations (Finanza e operazioni).
  3. Verificare che l'URL di destinazione possa essere aperto direttamente nel browser. Per ulteriori informazioni, vedere Configurare l'origine dati entità virtuale.

Errore 400 con "Impossibile risolvere il nome remoto"

Sintomi

Quando si imposta la visibilità della tabella virtuale o si esegue la ricerca dei dati master nella configurazione delle funzionalità fiscali, viene visualizzato il messaggio di errore seguente:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (400) Richiesta non valida. 0x80040224: TokenProvider.AcquireTokenAsync(Clientld '{ApplicationId}', Authority '{IncorrectURL}', Resource '00000015-0000-0000-c000-0000000000000'): unhandled exception: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: Service returned error. Per altri dettagli, vedere InnerException ---> System.Net.WebException: Impossibile risolvere il nome remoto:...

Causa

Questo problema si verifica se l'URL OAuth (Open Authorization) o l'ID tenant non è corretto. Per ulteriori informazioni, vedere Configurare l'origine dati entità virtuale.

Risoluzione

  1. Passare a Dataverse>Advanced settings>Administration Virtual Entity Data Sources (Amministrazione>origini dati entità virtuali) e selezionare l'origine dati denominata finance and operations (Finanza e operazioni).

  2. Verificare che l'URL OAuth e l'ID tenant siano corretti. Per ulteriori informazioni, vedere Configurare l'origine dati entità virtuale.

    • L'URL OAuth è un valore hardcoded: https://login.windows.net/.
    • Per trovare l'ID tenant corretto, accedere al portale di Azure usando lo stesso account usato per accedere a Dataverse e RCS. Selezionare Microsoft Entra ID e quindi selezionare l'istanza di Microsoft Entra ID. L'ID tenant o il dominio primario viene visualizzato nel campo Tenant .

Errore 400 con "Application with identifier {ApplicationId} not found" (Applicazione con identificatore {ApplicationId} non trovato)

Sintomi

Quando si imposta la visibilità della tabella virtuale o si esegue la ricerca dei dati master nella configurazione delle funzionalità fiscali, viene visualizzato il messaggio di errore seguente:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (400) Richiesta non valida. 0x80040224: TokenProvider.AcquireTokenAsync(Clientid '{IncorrectApplicationId}', Authority '<https://login.windows.net/microsoft.com>', Resource '00000015-0000-0000-c000-0000000000000'): unhandled exception: Microsoft.IdentityModel.Clients.ActiveDirectory.AdalServiceException: AADSTS700016: Application with identifier '{IncorrectApplicationId}' not found in the directory 'Microsoft'. Questa situazione può verificarsi se l'applicazione non è stata installata dall'amministratore del tenant o non è consentita da uno degli utenti nel tenant. È possibile che la richiesta di autenticazione sia stata inviata al tenant sbagliato.

Causa

Questo problema si verifica se l'ID applicazione non è corretto. Per ulteriori informazioni, vedere Configurare l'origine dati entità virtuale.

Risoluzione

  1. Passare a Dataverse>Advanced settings>Administration Virtual Entity Data Sources (Amministrazione>origini dati entità virtuali) e selezionare l'origine dati denominata finance and operations (Finanza e operazioni).
  2. Verificare che l'ID applicazione sia corretto. Per ulteriori informazioni, vedere Configurare l'origine dati entità virtuale.

È necessario ottenere l'ID applicazione durante il passaggio Registrare l'app nel passaggio portale di Azure. Assicurarsi di aver immesso l'ID applicazione corretto.

errore 401

Sintomi

Quando si imposta la visibilità della tabella virtuale, eseguire la ricerca dei dati master nella configurazione delle funzionalità fiscali o eseguire la convalida del mapping dei modelli, viene visualizzato uno dei messaggi di errore seguenti:

Connessione a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (401) Non autorizzato.

Connessione dell'entità Warehouse del warehouse filtrata a Microsoft Dataverse non riuscita. Dettagli: il server remoto ha restituito un errore: (401) Non autorizzato.

Causa

L'errore 401 "Non autorizzato" si verifica se il processo "Controlla connessione" per le applicazioni connesse in RCS non riesce o se il processo "Controlla connessione" non viene eseguito dopo che vengono apportate modifiche alle impostazioni delle applicazioni connesse in RCS.

Note

L'account usato per accedere a RCS deve anche essere in grado di accedere all'istanza di Dataverse.

Risoluzione

  1. Nell'ambiente RCS passare a Electronic Reporting>Connected applications>Dataverse application record (Record dell'applicazione Dataverse).
  2. Il campo Applicazione mostra l'URL dell'istanza del database. Verificare di poter accedere all'istanza di Dataverse usando lo stesso account usato per accedere all'ambiente RCS.
  3. Verificare che il campo Tenant sia impostato sull'ID tenant dell'account( ad esempio d335a570-a05b-4bc5-8eb3-c42c65f9560d) o l'URL del tenant (ad esempio). taxserviceint.onmicrosoft.com
  4. Selezionare Controlla connessione. Il processo deve avere esito positivo.

Importante

Se il processo "Verifica connessione" non riesce, l'installazione di Dataverse non è corretta. Vedere Abilitare la ricerca dei dati master per la configurazione del calcolo fiscale e assicurarsi che i passaggi 1, 2 e 3 vengano eseguiti correttamente.