L'app Field Service per dispositivi mobili mostra la home page in modo imprevisto e si verifica una reimpostazione di WebView
Questo articolo consente di risolvere e risolvere i problemi nell'app Dynamics 365 Field Service per dispositivi mobili, in cui la home page viene visualizzata in modo imprevisto e si verifica una reimpostazione di WebView.
Sintomi
L'app dynamics 365 Field Service per dispositivi mobili visualizza in modo imprevisto la home page e si verifica una reimpostazione di WebView.
Causa
WebView viene reimpostato per diversi motivi. Quando un dispositivo Android o iOS è insufficiente in memoria, chiude in modo proattivo le app per recuperare memoria. I processi che usano grandi quantità di memoria includono:
- Uso della fotocamera e caricamento di file di grandi dimensioni, ad esempio immagini, video, audio, PDF o altri documenti.
- Personalizzazioni come i controlli PCF (Component Framework) di PowerApps. Ad esempio, usando annotazioni con controlli personalizzati.
- Schermata di condivisione in Microsoft Teams.
- Esecuzione di altre app nel dispositivo.
Risoluzione
Provare i suggerimenti seguenti per attenuare il problema:
- Determinare la causa della reimpostazione. Usare gli strumenti di sviluppo per controllare l'utilizzo della memoria in WebView nell'app e nel browser. Ad esempio, eseguire il debug di JavaScript nell'app per dispositivi mobili in Android o Risolvere i problemi di memoria.
- Per ridurre l'utilizzo della memoria, ad esempio evitare la condivisione dello schermo o la chiusura di app diverse dall'app per dispositivi mobili Field Service che usano grandi quantità di memoria.
- Esaminare le considerazioni sulle prestazioni durante la personalizzazione dell'app per dispositivi mobili e intraprendere azioni per ridurre l'utilizzo della memoria.