Errore "Impossibile ottenere la versione del processo di inserimento Delta Lake"
Note
Il 1° settembre 2023 abbiamo unito e rinominato Dynamics 365 Marketing e Dynamics 365 Customer Insights. Dynamics 365 Marketing è ora denominato Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights è ora denominato Dynamics 365 Customer Insights - Data. Per ulteriori informazioni, vedi le Domande frequenti su Dynamics 365 Customer Insights.
Questo articolo consente di risolvere l'errore "Impossibile ottenere la versione del processo di inserimento Delta Lake" che può verificarsi quando ci si connette ai dati archiviati in formato Delta in Microsoft Dynamics 365 Customer Insights - Data.
Sintomi
Un'origine dati Delta in Dynamics 365 Customer Insights : i dati tentano di connettersi a una tabella che usa una funzionalità che richiede databricks minReaderVersion
o 3
versione successiva. In questo caso, nella pagina Origini dati viene visualizzato il messaggio di errore seguente:
Il processo di inserimento Delta Lake non è riuscito a ottenere la versione <DataSourceId>.
Quando si visualizzano le colonne nella tabella, viene visualizzato l'errore "Impossibile salvare lo schema dell'origine dati".
Causa
Dynamics 365 Customer Insights: i dati supportano le funzionalità di 2
Databricks con o minReaderVersion
versioni precedenti. Le funzionalità di Databricks che richiedono la versione 3
del lettore Databricks o versioni successive non sono supportate.
Risoluzione
Per risolvere questo problema, rimuovere la funzionalità dall'installazione di Databricks e ripristinare .minReaderVersion
2
Per altre informazioni, vedere Funzionalità e versioni supportate di Databricks.