Errore 0x800705B4 quando si attiva una macchina virtuale Windows di Azure
Si applica a: ✔️ macchine virtuali di Windows
Questo articolo fornisce una soluzione all'errore 0x800705B4 che si verifica quando si tenta di attivare una macchina virtuale Windows di Azure.
Sintomi
Quando si cerca di attivare una VM Windows di Azure, si riceve l'errore 0x800705B4:
Attivazione di Windows
Si è verificato un problema durante il tentativo di attivazione di Windows. Codice di errore 0x800705B4.
Per una possibile risoluzione, fare clic su Altre informazioni.
Per assistenza, contattare l'amministratore di sistema o il reparto di supporto tecnico.
Può anche essere visualizzato come errore Security-SPP (ID evento 8196) nel registro applicazioni.
Causa
Questo errore indica un timeout. Potrebbe essere causato da problemi di connettività di rete o Domain Name System (DNS).
Passaggi per la risoluzione dei problemi
Eseguire la procedura seguente per verificare i problemi di connettività di rete e quindi ripetere l'attivazione.
Verificare la connettività tra la macchina virtuale e il servizio del Servizio di gestione delle chiavi di Azure
Assicurarsi che la macchina virtuale sia configurata per l'uso del server di Azure Servizio di gestione delle chiavi s (KMS) corretto. A tale scopo, utilizzare il seguente comando:
Invoke-Expression "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /skms azkms.core.windows.net:1688"
Il comando dovrebbe restituire il testo seguente:
Nome macchina del Servizio di gestione delle chiavi impostato su
azkms.core.windows.net:1688
correttamente.Assicurarsi che il traffico di rete in uscita verso l'endpoint del Servizio di gestione delle chiavi sulla porta 1688 non sia bloccato dal firewall nella macchina virtuale. A tale scopo, eseguire il cmdlet di PowerShell Test-NetConnection o lo strumento PsPing .
Verificare eseguendo
Test-NetConnection
:Test-NetConnection azkms.core.windows.net -port 1688
Se la connettività è consentita, verrà visualizzato
TcpTestSucceeded: True
nell'output.Verificare usando PsPing. Passare alla cartella in cui è stato estratto l'archivio
Pstools.zip
ed eseguire il seguente comando:.\psping.exe azkms.core.windows.net:1688
Nella seconda riga dell'output assicurarsi di visualizzare il testo seguente:
Sent = 4, Received = 4, Lost = 0 (0% loss)
Se
Lost
è maggiore di 0 (zero), la macchina virtuale non ha connettività al server del Servizio di gestione delle chiavi. In questo caso, se la macchina virtuale si trova in una rete virtuale e ha specificato un server DNS personalizzato, è necessario assicurarsi che il server DNS sia in grado di risolvereazkms.core.windows.net
. In alternativa, modificare il server DNS con uno che risolvaazkms.core.windows.net
.Note
Se si rimuovono tutti i server DNS da una rete virtuale, le macchine virtuali utilizzeranno il servizio DNS interno di Azure. Questo servizio può risolvere
azkms.core.windows.net
.
Verificare di usare l'hop successivo di Azure Network Watcher che il tipo di hop successivo dalla macchina virtuale in questione agli INDIRIZZI IP
20.118.99.224
di destinazione e40.83.235.53
(perazkms.core.windows.net
) o all'indirizzo IP dell'endpoint del Servizio di gestione delle chiavi appropriato applicabile all'area è Internet.Se il risultato è VirtualAppliance o VirtualNetworkGateway, è probabile che esista una route predefinita. Contatta il tuo amministratore di rete e collabora per determinare la corretta linea d'azione. Potrebbe trattarsi di un percorso personalizzato se questa soluzione è conforme ai criteri dell'organizzazione.
Dopo aver verificato la corretta connettività a
azkms.core.windows.net
, eseguire il comando seguente al prompt di Windows PowerShell con privilegi elevati. Questo comando prova l'attivazione più volte:1..12 | ForEach-Object { Invoke-Expression "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /ato" ; start-sleep 5 }
Un'attivazione andata a buon fine restituisce informazioni simili alle seguenti:
Attivazione di Windows(R), edizione ServerDatacenter (12345678-1234-1234-1234-12345678)... Prodotto attivato con successo.
Contattaci per ricevere assistenza
In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.