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Attivazione di Windows: ID computer client duplicato

Si applica a: ✔️ macchine virtuali di Windows

In genere è consigliabile usare server Servizio di gestione delle chiavi di Azure per attivare macchine virtuali Windows di Azure, anche quando Vantaggio Azure Hybrid è abilitato. Tuttavia, in casi specifici, poiché le restrizioni di rete potrebbero impedire alle macchine virtuali di comunicare con i server del Servizio di gestione delle chiavi di Azure, è possibile usare un server del Servizio di gestione delle chiavi self-hosted per l'attivazione. Questo articolo illustra un problema di ID computer client duplicato che si verifica quando si usa un server del Servizio di gestione delle chiavi self-hosted per l'attivazione di Windows e fornisce una soluzione.

Note

Questo articolo si applica solo quando si usa un server del Servizio di gestione delle chiavi self-hosted per l'attivazione. Non si applica quando si usa il Servizio di gestione delle chiavi di Azure per l'attivazione.

Sintomi

Quando si usa un server del Servizio di gestione delle chiavi self-hosted per l'attivazione e si tenta di attivare più macchine virtuali Windows Server, l'attivazione ha esito negativo dopo il periodo di valutazione e il server del Servizio di gestione delle chiavi self-hosted segnala l'errore seguente nel report ID computer client duplicato:

Il report Duplicato ID computer client consente di identificare i computer nell'ambiente che eseguono immagini che non sono state generalizzate correttamente usando lo strumento Sysprep prima della distribuzione.
Nota:
- Più client di attivazione dei contratti multilicenza con lo stesso CMID verranno conteggiati come un singolo client dal Servizio di gestione delle chiavi. Se in questo modo il numero di client del Servizio di gestione delle chiavi scende al di sotto della soglia minima, l'attivazione del Servizio di gestione delle chiavi avrà esito negativo nell'ambiente.

Causa

  • L'ID computer client (CMID) viene cancellato durante il processo Sysprep dell'immagine di origine originale. Tuttavia, se il processo Sysprep viene attivato con il parametro SkipRearm impostato su 1 invece del valore predefinito di 0, cmid non verrà cancellato. In questo caso, tutte le macchine virtuali create da questa immagine avranno lo stesso CMID.

  • Quando si creano macchine virtuali da Azure Marketplace, le immagini di Azure Marketplace per Windows Server sono state generalizzate con il parametro SkipRearm impostato su 1. Di conseguenza, le macchine virtuali create dalla stessa immagine di Windows Server avranno lo stesso ID del computer del cliente.

Confermare CMID duplicato

Controllare se le macchine virtuali hanno lo stesso CMID in base all'immagine e alla versione di origine:

  1. Eseguire il comando seguente nelle macchine virtuali problematiche:

    cscript C:\Windows\System32\slmgr.vbs /dlv
    

    Ecco un esempio di output dei comandi:

    Most recent activation information:
    Key Management Service client information
        Client Machine ID (CMID): <client-machine-ID>
        Registered KMS machine name: <KMS-machine-name>
    
  2. Confrontare gli output dei comandi nelle macchine virtuali problematiche e verificare se le macchine virtuali hanno lo stesso CMID.

Soluzione

  • Per le macchine virtuali problematiche create da un'immagine personalizzata, generalizzare/sysprep la macchina virtuale originale con il parametro SkipRearm impostato su per 0 assicurarsi che cmid sia cancellato dall'immagine.

  • Per le macchine virtuali problematiche già distribuite, seguire questa procedura:

    1. Da un prompt dei comandi con privilegi elevati, eseguire il comando slmgr /rearm.

    2. Riavviare la macchina virtuale.

    3. Quando la macchina virtuale è online dopo il riavvio, eseguire il comando seguente per verificare che cmid sia stato modificato:

      cscript C:\Windows\System32\slmgr.vbs /dlv
      
    4. Attivare nuovamente l'attivazione.

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