Condividi tramite


Errore AADSTS50105: The signed in user is not assigned to a role for the application (Nessun ruolo assegnato all'utente che ha eseguito l'accesso per l'applicazione)

Questo articolo fornisce una risoluzione dell'errore AADSTS50105 che si verifica durante l'autenticazione federata con Microsoft Entra ID.

Note

Questo articolo è stato utile? Diamo importanza al contributo degli utenti. Usare il pulsante Feedback in questa pagina per comunicare se questo articolo è stato utile o come possiamo migliorarlo.

Sintomi

Quando si tenta di accedere a un'applicazione configurata per l'uso dell'ID Entra Di Microsoft per la gestione delle identità tramite Single Sign-On (SSO) basato su SAML, viene visualizzato il messaggio di errore seguente:

Errore AADSTS50105: l'utente connesso non è assegnato a un ruolo per l'applicazione.

Causa

L'utente non ha ottenuto l'accesso all'applicazione in Microsoft Entra ID. L'utente deve appartenere a un gruppo assegnato all'applicazione o essere assegnato direttamente.

Note

I gruppi annidati non sono supportati e il gruppo deve essere assegnato direttamente all'applicazione.

Risoluzione

Per assegnare uno o più utenti direttamente a un'applicazione, vedere Avvio rapido: assegnare utenti a un'app.

Ulteriori informazioni

Per un elenco completo dei codici di errore di autenticazione e autorizzazione di Active Directory, vedere Codici di errore di autenticazione e autorizzazione di Microsoft Entra.

Contattaci per ricevere assistenza

In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.