Risolvere i problemi relativi al codice di errore ERR_VHD_FILE_NOT_FOUND (65)
Questo articolo illustra come identificare e risolvere il ERR_VHD_FILE_NOT_FOUND
codice di errore (numero di codice errore 65) che si verifica quando si tenta di creare e distribuire un cluster del servizio Azure Kubernetes di Microsoft servizio Azure Kubernetes.
Sintomi
Quando si tenta di creare un cluster del servizio Azure Kubernetes, viene visualizzato il messaggio di errore seguente:
VMExtensionProvisioningError: la macchina virtuale ha segnalato un errore durante l'elaborazione dell'estensione "vmssCSE".
Messaggio di errore: "Enable failed: failed to execute command: command terminate with exit status=65
Causa
In rari casi, il codice di uscita 65 per l'estensione script personalizzata del set di scalabilità di macchine virtuali di Azure (vmssCSE
) potrebbe verificarsi invece dei codici di errore seguenti:
Nome del codice di errore | Numero di codice di errore |
---|---|
OutboundConnFailVMExtensionError |
50 |
K8SAPIServerConnFailVMExtensionError |
51 |
K8SAPIServerDNSLookupFailVMExtensionError |
52 |
Questo errore si verifica se esiste un problema di connettività tra il cluster del servizio Azure Kubernetes e gli endpoint di Azure necessari, ad esempio mcr.microsoft.com
o acs-mirror.azureedge.net
.
Soluzione
Per i passaggi dettagliati per la risoluzione dei problemi, vedere le guide alla risoluzione dei problemi negli articoli seguenti:
Risolvere i problemi relativi al codice di errore OutboundConnFailVMExtensionError (50)
Risolvere i problemi relativi al codice di errore K8SAPIServerConnFailVMExtensionError (51)
Risolvere i problemi relativi al codice di errore K8SAPIServerDNSLookupFailVMExtensionError (52)
Riferimenti
Risoluzione generale dei problemi di creazione del cluster del servizio Azure Kubernetes
Regole di rete e FQDN in uscita per cluster servizio Azure Kubernetes (servizio Azure Kubernetes)
Contattaci per ricevere assistenza
In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.