Risolvere gli errori node not ready seguiti dai ripristini
Questo articolo fornisce una guida alla risoluzione dei problemi relativi ai nodi non pronti nei cluster servizio Azure Kubernetes (AKS). Quando un nodo entra in uno stato "Non pronto", può interrompere la funzionalità dell'applicazione e impedirne la risposta. In genere, il nodo viene ripristinato automaticamente dopo un breve periodo. Tuttavia, per evitare problemi ricorrenti e mantenere un ambiente stabile, è importante comprendere le cause sottostanti per poter implementare soluzioni efficaci.
Causa
Esistono diversi scenari che potrebbero causare l'esecuzione di uno stato "Non pronto":
Mancata disponibilità del server API. In questo modo il probe di idoneità non riesce. Ciò impedisce che il pod venga collegato al servizio in modo che il traffico non venga più inoltrato all'istanza del pod.
Errori dell'host della macchina virtuale (VM). Per determinare se si sono verificati errori dell'host della macchina virtuale, controllare le origini informazioni seguenti:
- Diagnostica del servizio Azure Kubernetes
- Stato di Azure
- Notifiche di Azure (per eventuali interruzioni recenti o periodi di manutenzione)
Risoluzione
Controllare la disponibilità del server API eseguendo il kubectl get apiservices
comando . Assicurarsi che il probe di idoneità sia configurato correttamente nel file YAML di distribuzione.
Per altri passaggi, vedere Risoluzione dei problemi di base degli errori node non pronti.
Prevenzione
Per evitare che questo problema si verifichi in futuro, eseguire una o più delle azioni seguenti:
- Assicurarsi che il livello di servizio sia completamente pagato.
- Ridurre il numero di
watch
richieste eget
al server API.