La cassetta postale di destinazione non ha una corrispondenza proxy SMTP in una migrazione della cassetta postale
Problema
Si supponga di avere una distribuzione ibrida di Microsoft Exchange Server locale ed Exchange Online in Microsoft 365. Quando si tenta di spostare le cassette postali dall'ambiente locale a Exchange Online, viene visualizzato il messaggio di errore seguente:
La cassetta postale di destinazione non dispone di un proxy smtp corrispondente a '<domain.mail.onmicrosoft.com>'
Causa
Questo problema può verificarsi se una delle seguenti condizioni è vera:
- La cassetta postale di origine non è contrassegnata per avere un <indirizzo smtp domain.mail.onmicrosoft.com>.
- L'indirizzo <proxy domain.mail.onmicrosoft.com> non viene sincronizzato con Microsoft 365 nell'oggetto utente di posta elettronica cloud corrispondente.
Soluzione
Per individuare la causa del problema e determinare da quale cassetta postale manca l'indirizzo <di posta elettronica domain.mail.onmicrosoft.com>, eseguire i comandi seguenti in Exchange Management Shell ed Exchange Online PowerShell:
In Exchange Management Shell locale:
Get-Mailbox <AffectedUser> | FL EmailAddresses, EmailAddressPolicyEnabled
In PowerShell di Exchange Online:
Get-MailUser <AffectedUser> | Select -ExpandProperty emailaddresses
Scenario 1: <indirizzo di posta elettronica domain.mail.onmicrosoft.com> mancante nella cassetta postale di origine locale (Exchange Management Shell)
Per risolvere questo problema, aggiungere l'indirizzo <di posta elettronica domain.mail.onmicrosoft.com> alla cassetta postale di origine locale.
Se alla cassetta postale locale è applicato un criterio di indirizzo di posta elettronica, ovvero il valore del parametro EmailAddressPolicyEnabled è True o la casella di controllo Aggiorna automaticamente gli indirizzi di posta elettronica in base ai criteri di indirizzo di posta elettronica applicati a questo destinatario è selezionata per l'utente nell'interfaccia di amministrazione di Exchange o in Exchange Management Console, significa che i criteri di indirizzo di posta elettronica non contengono il dominio> SMTP <secondario.mail.onmicrosoft.com dominio nel modello di criteri dell'indirizzo di posta elettronica. È possibile ricontrollare questo criterio eseguendo il comando seguente in Exchange Management Shell:
Get-EmailAddressPolicy | FL Identity, EnabledEmailAddressTemplates
In questo caso, aggiungere <domain.mail.onmicrosoft.com> ai criteri dell'indirizzo di posta elettronica. A tal fine, attenersi alla seguente procedura:
Aprire l'interfaccia di amministrazione di Exchange nel server Exchange locale.
Fare clic su Flusso di posta elettronica e quindi su Criteri indirizzo di posta elettronica.
Selezionare i criteri dell'indirizzo di posta elettronica che si desidera modificare e quindi fare clic su Modifica.
Nel formato indirizzo di posta elettronica aggiungere il dominio (<domain.mail.onmicrosoft.com>) al criterio, fare clic su Salva e quindi fare clic su Applica a per applicare la modifica ai destinatari.
Si notrà ora che l'indirizzo <SMTP domain.mail.onmicrosoft.com> viene contrassegnato nella cassetta postale locale quando si esegue il comando seguente:
Get-Mailbox <AffectedUser> | FL EmailAddresses, EmailAddressPolicyEnabled
Attendere l'esecuzione della sincronizzazione della directory. In alternativa, forzare una sincronizzazione della directory delta. Per altre informazioni su come eseguire questa operazione, vedere Avviare l'utilità di pianificazione.
Se alla cassetta postale locale non è applicato un criterio di indirizzo di posta elettronica, ovvero il valore del parametro EmailAddressPolicyEnabled è False o la casella di controllo Aggiorna automaticamente gli indirizzi di posta elettronica in base ai criteri di indirizzo di posta elettronica applicati a questo destinatario non è selezionata per l'utente nell'interfaccia di amministrazione di Exchange o nella Console di gestione di Exchange oppure se, per qualsiasi motivo, i criteri di indirizzo di posta elettronica non contrassegnano o applicano il user@domain.mail.onmicrosoft.com criterio indirizzo smtp nel destinatario, è necessario aggiungere manualmente l'indirizzo <di posta elettronica domain.mail.onmicrosoft.com> all'utente e quindi sincronizzare la modifica in ID Microsoft Entra. A tal fine, attenersi alla seguente procedura:
Aprire l'interfaccia di amministrazione di Exchange nel server Exchange locale.
Fare clic su destinatari e quindi su cassette postali.
Selezionare e fare doppio clic sulla cassetta postale locale da modificare.
Negli indirizzi di posta elettronica fare clic sull'icona aggiungi () per aggiungere user@domain.mail.onmicrosoft.com l'indirizzo di posta elettronica agli indirizzi di posta elettronica dell'utente.
Fare clic su OK e quindi su Salva.
Verrà visualizzato il <file domain.mail.onmicrosoft.com> stampato nella cassetta postale locale quando si esegue il comando seguente:
Get-Mailbox <AffectedUser> | FL EmailAddresses
Attendere l'esecuzione della sincronizzazione della directory. In alternativa, forzare una sincronizzazione della directory delta. Per altre informazioni su come eseguire questa operazione, vedere Avviare l'utilità di pianificazione.
Scenario 2: <l'indirizzo di posta elettronica domain.mail.onmicrosoft.com> viene contrassegnato nella cassetta postale di origine locale, ma non è presente nell'oggetto utente di posta elettronica cloud (PowerShell di Exchange Online)
In questo caso, probabilmente si verifica un problema di sincronizzazione. Determinare se la sincronizzazione della directory funziona e se sono presenti errori di sincronizzazione segnalati nello strumento Microsoft Entra Connect o nell'interfaccia di amministrazione di Microsoft 365. Per altre informazioni su come eseguire questa operazione, vedere Visualizzare gli errori di sincronizzazione della directory in Microsoft 365.
È anche possibile che si verifichi un errore di convalida dell'utente, se si dispone già di un oggetto utente cloud in cui viene stampato l'indirizzo user@domain.mail.onmicrosoft.com di posta elettronica.
Per visualizzare questo errore, è necessario connettersi a Microsoft 365 PowerShell ed eseguire uno dei comandi seguenti, a seconda che ci si connetta al servizio MSOnline (MSOL) o a Microsoft Entra ID per Windows PowerShell:
(Get-MsolUser -UserPrincipalName <AffectedUserUPN>).Errors.ErrorDetail.ObjectErrors.ErrorRecord.ErrorDescription
(Get-AzureADUser -ObjectId <AffectedUserUPN>).Errors.ErrorDetail.ObjectErrors.ErrorRecord.ErrorDescription
Nota
I moduli PowerShell di Azure AD e MSOnline saranno deprecati a partire dal 30 marzo 2024. Per ulteriori informazioni, leggere l'aggiornamento sulla deprecazione. Dopo questa data, il supporto per questi moduli è limitato all'assistenza per la migrazione a Microsoft Graph PowerShell SDK e alle correzioni per la sicurezza. I moduli deprecati continueranno a funzionare fino al 30 marzo 2025.
È consigliabile effettuare la migrazione a Microsoft Graph PowerShell per interagire con Microsoft Entra ID (in precedenza Azure AD). Per le domande più comuni sulla migrazione, consultare Domande frequenti sulla migrazione. Nota: le versioni 1.0.x di MSOnline potrebbero subire interruzioni dopo il 30 giugno 2024.
Per altre informazioni, vedere Visualizzare gli errori di convalida per gli utenti nel portale di Microsoft 365 o nel modulo Azure Active Directory per Windows PowerShell.
In Microsoft 365 PowerShell controllare quindi se gli indirizzi proxy in Microsoft Entra ID contengono l'indirizzo user@domain.mail.onmicrosoft.comdi posta elettronica . A tale scopo, eseguire uno dei comandi seguenti:
(Get-MsolUser -UserPrincipalName <AffectedUserUPN>).ProxyAddresses
(Get-AzureADUser -ObjectId <AffectedUserUPN>).ProxyAddresses
Se si trova l'indirizzo user@domain.mail.onmicrosoft.com smtp per l'utente nel risultato del comando, ma non si dispone ancora di questo indirizzo di posta elettronica in Exchange Online PowerShell usando il Get-MailUser
comando , ciò significa che lo strumento di sincronizzazione della directory ha portato correttamente l'indirizzo nell'ID Microsoft Entra e probabilmente si verifica un problema di sincronizzazione tra Microsoft Entra ID ed Exchange Online.
Un'altra causa può essere se il dominio smtp domain.mail.onmicrosoft.com contrassegnato per l'utente locale non è corretto. Ad esempio, il dominio non esiste nel tenant di Microsoft 365 o nei domini accettati di Exchange Online. Per altre informazioni sui domini accettati, vedere Visualizzare i domini accettati.
Se non è possibile determinare la causa del problema, aprire un caso di supporto con il team di supporto Microsoft per approfondire l'analisi.
Ulteriori informazioni
Per altre informazioni sui criteri degli indirizzi di posta elettronica e sulle distribuzioni ibride di Exchange, vedi la sezione "Criteri indirizzo di posta elettronica" del post di blog The cloud on your terms (PART I): deploying hybrid .
Per altre informazioni su come modificare i criteri di un indirizzo di posta elettronica, vedi Modificare i criteri di un indirizzo di posta elettronica.
Per altre informazioni sul dominio di coesistenza aggiunto dalla configurazione guidata ibrida, vedere la voce "Domini" nella Configurazione guidata ibrida.
Ulteriore assistenza Visitare la community Microsoft o i forum TechNet di Exchange.