Condividi tramite


Risoluzione dei problemi relativi agli strumenti di BizTalk Server

Questo argomento fornisce una posizione centralizzata per informazioni sui problemi comuni riscontrati durante l'uso degli strumenti inclusi in BizTalk Server.

Problemi noti

È possibile che Strumenti e utilità di BizTalk Server non funzioni correttamente su un sistema Windows che supporta UAC

Problema

Quando BizTalk Server è installato in un sistema che supporta controllo account utente, gli strumenti inclusi in BizTalk Server potrebbero non essere attivati correttamente o potrebbero non funzionare correttamente.

Causa

Quando viene eseguita un'applicazione contrassegnata per un livello di privilegi specifico, se il livello richiesto è superiore a quello dell'utente che esegue l'applicazione, in UAC verrà visualizzata una richiesta che consente di elevare temporaneamente i privilegi dell'applicazione al livello richiesto. Gli strumenti forniti con BizTalk Server non hanno i flag corretti abilitati per richiedere automaticamente l'elevazione dei privilegi, quindi lo strumento tenterà di eseguire a livello di privilegio corrente dell'utente che esegue l'applicazione e avrà esito negativo se è necessario un livello di privilegi più elevato.

Risoluzione

Per risolvere il problema, eseguire tutti gli strumenti di BizTalk Server con privilegi di amministratore. Per eseguire uno strumento con privilegi amministrativi, fare clic con il pulsante destro del mouse sull'applicazione e quindi selezionare Esegui come amministratore.

Per altre informazioni sul controllo account utente, vedere https://go.microsoft.com/fwlink/?LinkId=99167.

A volte la Casella degli strumenti di BizTalk Mapper può essere visualizzata vuota

Problema

Talvolta, quando si apre la Casella degli strumenti di Mapper in Visual Studio, non viene visualizzato alcun functoid.

Causa

Si tratta di un probabile danneggiamento causato dall'installazione o disinstallazione di componenti aggiuntivi e/o patch di Visual Studio.

Risoluzione

Per risolvere questo problema:

  1. Chiudere tutte le istanze di Visual Studio in esecuzione.

  2. Avviare il prompt dei comandi di Visual Studio come amministratore.

  3. Al prompt dei comandi digitare il comando seguente:

    devenv.exe /setup