Risoluzione dei problemi relativi all'amministrazione di BizTalk Server
In questa sezione vengono riepilogate le informazioni relative ai problemi comunemente riscontrati durante l'utilizzo della console di amministrazione di BizTalk Server.
Oltre ai problemi noti seguenti, i problemi comuni e le soluzioni con la console di amministrazione di BizTalk Server forniscono informazioni aggiuntive.
Problemi noti
Un ritardo nel servizio ENTSSO impedisce l'avvio del servizio BizTalk Server
Problema
Il riavvio del computer eseguito con il servizio DTC non impostato sull'avvio automatico può impedire l'avvio del servizio BizTalk Server.
Causa
Il problema si verifica perché l'avvio del servizio ENTSSO può richiedere una quantità di tempo maggiore rispetto a quella consentita dalla durata del timeout del servizio BizTalk Server.
Soluzione
Per risolvere il problema, impostare DTC su automatico. Se DTC è in cluster, deve essere impostato sull'avvio manuale perché il servizio cluster gestisce l'avvio e l'arresto dei servizi cluster.
Possibile blocco delle risorse SQL
Problema
È possibile che venga visualizzato il seguente messaggio di errore:
La transazione (ID di processo 95) è stata interrotta a causa di un deadlock delle risorse di blocco con un altro processo. Ripetere la transazione.
Causa
Questa situazione si verifica molto raramente quando le operazioni amministrative eseguite da un utente comportano l'esclusione di un altro utente dall'amministrazione del database.
Soluzione
Il problema dovrebbe risolversi automaticamente in breve tempo. Riprovare a eseguire l'operazione dopo pochi minuti.
Possibile blocco del database SQL
Problema
L'accesso degli utenti al database SQL potrebbe essere bloccato. È possibile che vengano visualizzati diversi messaggi di errore.
Causa
In alcuni casi, quando un utente esegue un'operazione di scrittura nel database, l'accesso degli altri utenti viene bloccato.
Soluzione
Il problema dovrebbe risolversi automaticamente in breve tempo. Riprovare a eseguire l'operazione dopo pochi minuti.
La chiusura di più istanze del servizio in un ambiente con più database MessageBox non viene completata generando un errore
Problema
Il tentativo di chiudere più istanze del servizio dalla Console di amministrazione BizTalk Server non riesce e viene visualizzato un messaggio di errore analogo al seguente:
SQL Server ha bloccato l'accesso alla routine 'sys.xp_sqlagent_enum_jobs' del componente 'Agent XPs' perché tale componente è disabilitato in base alla configurazione di sicurezza del server.
Nota
Questo problema si verifica in un ambiente con più database MessageBox.
Causa
Questo problema può verificarsi in un ambiente a più messaggi se il processo di SQL Agent 'Operations_OperateOnInstances_OnMaster_<dbName>' non è in esecuzione nei database della finestra di messaggio secondaria. È necessario che tale processo sia in esecuzione affinché vengano propagate informazioni dai database MessageBox secondari a quello primario. Il processo non viene eseguito se non è abilitato o se si verifica un errore di accesso.
Soluzione
Se si usa la console di amministrazione BizTalk per eseguire operazioni su più istanze del servizio contemporaneamente e l'ambiente BizTalk Server è configurato con più database messagebox, verificare che il processo SQL Server Agent denominato "Operations_OperateOnInstances_OnMaster_<dbName>" sia abilitato in tutti i database messagebox secondari (non master). È inoltre necessario che nel computer SQL Server che ospita i database MessageBox secondari il servizio SQL Server Agent venga eseguito con un account incluso nel ruolo BTS_SQLAGENT_USER del database MessageBox secondario.
Nota
<Dbname> è un segnaposto per il nome effettivo del database messagebox BizTalk.
Per aggiungere l'account del servizio SQL Server Agent al ruolo BTS_SQLAGENT_USER del database MessageBox secondario, eseguire le operazioni seguenti:
In SQL Server 2008
Fare clic sul pulsante Start, scegliere Tutti i programmi, Microsoft SQL Server 2008 e quindi fare clic su SQL Server Management Studio.
Quando richiesto, scegliere il tipo di server del motore di database e immettere o selezionare il nome del server che ospita il database della casella di messaggio secondario.
Fare clic per espandere Database, fare clic per espandere il database della finestra di messaggio secondario, fare clic per espandere Sicurezza, fare clic su Ruoli per espandere Ruoli databasee quindi fare doppio clic sul ruolo del database BTS_SQLAGENT_USER.
Fare clic su Add .
Fare clic su Sfoglia, selezionare un gruppo di cui l'account del servizio SQL Server Agent è membro e quindi fare clic su OK.
Nota
Se l'account del servizio SQL Server Agent non è membro del gruppo specificato, sarà necessario aggiungerlo.
Le modifiche applicate a un'istanza della console di amministrazione BizTalk non vengono aggiornate automaticamente nelle altre istanze della console.
Problema
Se più istanze della console di amministrazione BizTalk vengono connesse simultaneamente allo stesso gruppo BizTalk Server, le modifiche apportate a un'istanza della console non verranno applicate automaticamente alle altre istanze in essa presenti. Ciò può generare errori di violazione della concorrenza quando si tenta di modificare un elemento visualizzato in un'istanza della console di amministrazione BizTalk, se lo stato di tale elemento non corrisponde allo stato effettivo memorizzato nel database di gestione BizTalk.
Causa
Ogni istanza della console di amministrazione BizTalk gestisce la propria cache di configurazione del gruppo BizTalk e riflette solo le modifiche apportate in tale cache. La cache viene aggiornata solo in seguito all'aggiornamento della visualizzazione della console di amministrazione BizTalk.
Risoluzione
Se si ricevono errori di violazione della concorrenza nella console di amministrazione BizTalk, aggiornare la cache per l'istanza della console di amministrazione BizTalk facendo clic sul pulsante Aggiorna sulla barra degli strumenti della console di amministrazione BizTalk o premendo il tasto F5 .
Viene visualizzato l'errore "Impossibile eseguire l'azione di esecuzione 'Stop'" quando si tenta di arrestare un'orchestrazione con la console di amministrazione BizTalk
Problema
Quando si tenta di arrestare un'orchestrazione nella console di amministrazione BizTalk, viene generato un messaggio di errore simile al seguente:
Failed to execute action 'Stop'.
------------------------------
ADDITIONAL INFORMATION:
A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.) (Microsoft SQL Server, Error: 10054)
Questo problema può verificarsi se sussistono una o più condizioni seguenti:
La console di amministrazione BizTalk è aperta.
Il database di gestione BizTalk è installato in un'istanza cluster di SQL Server.
Si è verificato il failover dell'istanza cluster di SQL Server.
A termine del failover, si tenta di arrestare un'istanza in esecuzione di un'orchestrazione utilizzando la console di amministrazione BizTalk.
Causa
La console di amministrazione BizTalk gestisce una connessione al database di gestione BizTalk Server. Quando la connessione a BizTalk Server database di gestione è stata interrotta durante il failover, alcune attività di gestione potrebbero restituire un errore "Non riuscito a connettersi" o "Non è stato possibile eseguire" fino a quando la console di amministrazione BizTalk non è stata chiusa e riaperta.
Risoluzione
Chiudere e riaprire la console di amministrazione BizTalk. Quando la console di amministrazione BizTalk viene riaperta, viene creata una nuova connessione al database di gestione BizTalk Server specificato.
I nomi dei gruppi di Windows eliminati in precedenza non dispongono di accesso ai database BizTalk Server
Problema
Se, quando si reinstalla BizTalk Server, si usa un nome di gruppo di Windows eliminato in precedenza, il gruppo di Windows non avrà accesso ai database BizTalk Server.
Causa
L'eliminazione di un gruppo di Windows e la successiva creazione di un nuovo gruppo con lo stesso nome genera un nuovo identificatore di protezione (SID) per il gruppo di Windows. L'identificatore precedente, tuttavia, resta memorizzato nella cache di SQL Server e pertanto il nuovo gruppo di Windows non può accedere a SQL Server.
Risoluzione
Quando si elimina il gruppo di Windows, è anche necessario rimuoverne l'account di accesso di SQL Server.
L'amministratore BizTalk non può avviare la console di amministrazione BizTalk Server
Problema
Un amministratore BizTalk (membro del gruppo di Windows Amministratori BizTalk) potrebbe non essere in grado di aprire la Console di amministrazione BizTalk Server se non è un membro del gruppo Administrators di Windows nel computer locale.
Causa
Questo problema può verificarsi se BizTalk Server è stato reinstallato o riconfigurato. In questi casi, SQL Server utilizza gli ID di protezione memorizzati nella cache.
Risoluzione
Aggiungere temporaneamente l'amministratore BizTalk al gruppo locale Administrators di Windows nel computer locale. Dopo aver aperto la console di amministrazione BizTalk Server, rimuovere l'amministratore BizTalk da tale gruppo.
Non è possibile avviare un'istanza host su un computer remoto
Problema
Quando si crea un'istanza di Host BizTalk in un computer remoto, è possibile che venga visualizzato l'errore seguente all'avvio dell'istanza dell'host BizTalk: "Non è stato possibile avviare a causa di un errore di accesso".
Causa
Questo errore può verificarsi se sono state immesse credenziali non valide per l'account di servizio con il quale viene eseguita l'istanza host BizTalk o se l'account di servizio non dispone di diritti di accesso come servizio.
Risoluzione
Assegnare il diritto di accesso come servizio all'account di servizio nel computer remoto prima di avviare l'istanza host BizTalk. Questa operazione viene eseguita automaticamente su un computer locale, ma deve essere eseguita manualmente su un computer remoto.
La creazione o la configurazione di un'istanza di host su un sistema X64 con l'opzione solo 32 bit selezionata ha esito negativo
Problema
Nella console di amministrazione di BizTalk Server, la creazione di un'istanza host BizTalk in un computer X64 con l'opzione selezionata solo a 32 bit (impostazione predefinita) potrebbe non riuscire.
In Gestione configurazione BizTalk Server, quando si configura il runtime BizTalk Server in un sistema X64, la creazione o la configurazione di un'istanza di host in-process o di tipo isolato con l'opzione solo 32 bit selezionata potrebbe impedire l'avvio del servizio.
Causa
Sconosciuto
Risoluzione
Il problema è intermittente. Tentare di creare o configurare di nuovo l'host oppure deselezionare l'opzione solo 32-bit.
L'eliminazione dell'istanza host non comporta la cancellazione delle informazioni del Registro di sistema
Problema
Se l'utente non ha un ruolo di amministratore nel computer locale, in seguito all'eliminazione di un host di tipo In-Process o Isolato, verrà visualizzato un messaggio di errore di accesso negato. È possibile eliminare l'host forzatamente. Questa modalità di eliminazione, tuttavia, non comporta la cancellazione di tutte le informazioni del Registro di sistema correlate.
Causa
Per poter eliminare le informazioni del Registro di sistema relative a un'istanza host è necessario disporre dei privilegi di amministratore.
Risoluzione
Prima di eliminare l'host, accedere con l'account di amministratore locale in modo da rimuovere anche le informazioni del Registro di sistema correlate.
Non è possibile eliminare un database MessageBox
Problema
Potrebbe non essere possibile eliminare un database MessageBox. Se l'eliminazione non riesce, potrebbe essersi verificata una delle condizioni seguenti:
L'intervallo di aggiornamento della cache non è scaduto.
Il database MessageBox contiene istanze incomplete.
Se l'intervallo di aggiornamento della cache non è ancora scaduto, il messaggio di errore seguente viene visualizzato quando l'eliminazione ha esito negativo: "MessageBox non può essere eliminato poiché potrebbe essere presente un lavoro rimanente in MessageBox. Accertarsi che non siano presenti istanze incomplete nel MessageBox e riprovare."
Causa
L'intervallo di aggiornamento della cache deve scadere nel lasso di tempo che intercorre tra la disattivazione della pubblicazione di nuovi messaggi nel database MessageBox e l'eliminazione del database. Per impostazione predefinita, l'intervallo di aggiornamento della cache è 60 secondi.
Risoluzione
Per eliminare un database MessageBox, è innanzitutto necessario disattivare la pubblicazione di nuovi messaggi per tale database e quindi attendere la scadenza dell'intervallo di aggiornamento della cache, prima di procedere all'effettiva eliminazione.
Se il database MessageBox contiene istanze di servizio incomplete, viene visualizzato il messaggio di errore seguente: "MessageBox non può essere eliminato perché potrebbe comunque contenere istanze incomplete. Accertarsi che non siano presenti istanze incomplete nel MessageBox e riprovare".
Per visualizzare le istanze incomplete del servizio nel database MessageBox, è possibile utilizzare la pagina Hub gruppo nella Console di amministrazione BizTalk Server. Per informazioni sulla visualizzazione dello stato delle istanze del servizio nella pagina Hub di gruppo, vedere Come cercare istanze del servizio monitorate.